• Resolved elaraweb

    (@elaraweb)


    Hi,

    I changed the ‘supports’ parameters for my CPT and the calendar option in my post edit page is gone. It does not show under screen options either.

    I know the CPT needs to support the Editor & Custom Fields, but even with both options supported (and all of the others via ACF Extended), the calendar option does not show on my single post.

    The calendar options initially showed. I changed the CPT supports parameters, and the calendar options disappeared. I changed the CPT supports parameters back, the calendar options haven’t returned and aren’t listed under screen options.

    The calendar option still shows fine for all other CPT’s / posts, apart from the one I actually want it to show on.

    I’ve tried disabling / reenabling the plugin.

    Thanks

    • This topic was modified 10 months, 2 weeks ago by elaraweb.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter elaraweb

    (@elaraweb)

    Disabling ‘supports editor’ makes the calendar option reappear.

    Plugin Author Jonathan Jernigan

    (@apexws)

    Hi @elaraweb,

    Sorry you’re having trouble. I’ll do my best to help track down the issue and see if we have a bug in play.

    Do you happen to have the Classic Editor plugin installed?

    Plugin Author Spellhammer

    (@spellhammer)

    Hey @elaraweb,

    Since we haven’t heard from you in a few days, I’m going to mark this as resolved.

    If you’re still having trouble, feel free to email support@piecalendar.com so we can take a more thorough look at this for you.

    Thread Starter elaraweb

    (@elaraweb)

    Hey, sorry for the slow reply, I’m away on holiday.

    I don’t have the classic editor plugin installed, but I have disabled Gutenberg via Advanced Scripts which I’m guessing has the same outcome.

    Thanks

    Plugin Author Jonathan Jernigan

    (@apexws)

    Hey again @elaraweb,

    I just tested in a fresh install on my side. With a CPT created via CPTUI, I disabled “editor”, but left “custom-fields” enabled. I see the Pie Calendar meta box as intended. You can see that below:

    I then installed the Classic Editor plugin just for curiosity sake and still see exactly what is shown in the screenshot above.

    I assume the specific Gutenberg-disabling script you’re using is the culprit. Can you try temporarily disabling that snippet to see if it resolves the issue?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Updating CPT Bug’ is closed to new replies.