Support » Fixing WordPress » Updating behind Proxy

  • Hi!

    i recently updated our Intranet WP installation to 5.3 and can’t update neither WP nor any plugins since then.

    The Site is running behind a SSL-Scanning Proxy Server. I configured wp-config.php to use the proxy and credentials and copied the proxy SSL certificates to wp-includes/certificates.
    This worked fine in all 4.x versions but now throws an error when i try to download or update anything:

    An error occurred while updating 2J SlideShow: Download failed. A valid URL was not provided.

    The system is running on Ubuntu 18.04.3 LTS, Apache 2 2.4.29 and PHP 7.4.2

    Is there anything i can do?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Potentially you can whitelist requests to *.wordpress.org on the proxy server.

    Otherwise, you may have to implement a manual workaround by downloading the updated files from a machine that can get outside of your proxy, and then uploading those files to the server and doing a manual upgrade/update process.

    Sadly i don’t have any control over the proxy as it is corporate.

    Is there a way to downgrade to 4.x, as it worked fine in these versions?

    Is there already a solution? I have the same problem.

    There doesn’t seem to be one. It is still unusable to this day. Normal connectivity, like loading ads for plugins or listing them works fine. Only updating produces an error

    Maybe it is helpful, I obeserved also an error for fetching data from RSS feeds with the WordPress RSS Feed Retriever. It seems to be the same problem.

    juergenstadler

    (@juergenstadler)

    I finally was able to fix this mess! I don’t know what did the trick, or if it was a combination of it all, but my wp updates now!

    What i changed:

    – Checked the proxy settings in wp-config.php
    – Added SSL-Scanning Proxy certificates to /wp-incluedes/certificates
    – Added SSL-Scanning Proxy and CA-Certificates to Debian Certificate Store
    – Configured Curl to use proxy

    Hope it helps!

    juergenstadler

    (@juergenstadler)

    Nevermind, after updating everything it is broken again…

    But this is interesting to here, thanks! Can you give me a hint, what you did in the SSL-Scanning Proxy part? I can not find something useful, when I google it.

    Hi,

    sorry for the late reply, i am drowning in work 🙁

    What do you mean by SSL-Scanning part? Our corporation got a SSL-Scanning proxy which my wordpress Server is running behind.
    This is why it can’t connect to the internet without correct proxy settings.

    The only steps i could figure out were the ones i listed above, but thy seem broken again too :/

    Hi,

    i’m facing the same problem.
    What did you do with “Configured Curl to use proxy” ?

    You can set a global proxy in your /etc/environment file. Curl should then use it.
    I won’t post a step by step here, because there is thousands of posts online where this is solved.
    But still, even if you do this you can’t update at the moment. At least in my case

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.