Support » Plugin: Easy Theme and Plugin Upgrades » Updating a Plug In

  • I just downloaded this earlier this week and it worked perfectly in updating a plug in that I had a zip file for. Today, the same Plug In sent an update notice, but this time I got a message that the PlugIn installation failed, see below. Any ideas from anyone on what went wrong and how to fix it. (It should have taken me from 7.0.7 to 7.0.8). I really liked the way this worked easlier this week, eliminating my need to delete and re-install for the update.

    Installing Plugin from uploaded file: codecanyon-11322180-yellow-pencil-visual-css-style-editor.zip
    Unpacking the package…
    Installing the plugin…
    The package could not be installed. No valid plugins were found.
    Plugin installation failed.

Viewing 1 replies (of 1 total)
  • Plugin Author Chris Jean

    (@chrisjean)

    The “No valid plugins were found” error message comes from WordPress. It means that the zip file does not appear to contain a valid plugin. I can think of two likely causes of this problem:

    1. The plugin zip that you downloaded is invalid either due to a mistake by the developer or the system that creates the zip files.
    2. You have Mac that automatically unzipped the download resulting in your having to manually rezip the files. By doing this, you may have accidentally changed the contents resulting in the creation of an invalid plugin zip.

    The contents of a valid zip file typically looks like the following:

    plugin-name/plugin-name.php
    plugin-name/readme.txt
    plugin-name/other-file.php
    ...

    If the plugin directory is missing in the zip, such as the following, the plugin zip is not valid:

    plugin-name.php
    readme.txt
    other-file.php
    ...

    If the plugin directory is double-nested in the zip, such as the following, the plugin zip is not valid:

    plugin-name/plugin-name/plugin-name.php
    plugin-name/plugin-name/readme.txt
    plugin-name/plugin-name/other-file.php
    ...

    From the information provided, I can’t tell if the issue is #1, #2, or something else such as just a bad download. That said, the problem is definitely due to the zip file not containing a valid plugin.

Viewing 1 replies (of 1 total)
  • The topic ‘Updating a Plug In’ is closed to new replies.