Support » Fixing WordPress » Updates not showing up for everyone

  • We’ve had an issue on our site for several weeks now. I talked to our host and nothing they suggested has worked.

    Any time we make a new post on the site, not everyone can see it. The problem seems to vary whether it’s on a device or a PC or laptop. And when we have a post and make an update to that particular post, not everyone can see the updates to the post. We continually clean out the cache and that doesn’t help. It’s very aggravating. Not sure what else to do other than back up the site and reinstall WordPress. Any advice would be appreciated.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • This is most likely an upstream or “in-built” cache or CDN at your host. Are you on GoDaddy’s Managed WordPress hosting? Are you able to provide a URL that is currently having the problem so I can run some tests?

    • This reply was modified 3 days, 8 hours ago by  George Appiah.

    Yes, it is on GoDaddy’s Managed WordPress hosting.

    The link is insidedirtracing.com

    Hi, I had the same problem earlier today. I went to the edit blog and on the page where the content is i opened the Block data tap. It showed me that everything was correct so i drilled down and opened the ||P view html tab. Ok < p font-size:0;> that means that the writing is going to be zero size thus invisible. Change it to < p font-size:12;> You will get a nasty error message that makes it seem like your going to end the world but it will give you two options go with the new html or change to block.
    (if that doesn’t get an error message just change to <p font:12;> that should work as well).
    if you change to block the inline html code will be removed and wala… your content will be visible.
    Hope this helps.

    @schaarsmith1,

    Ok < p font-size:0;> that means that the writing is going to be zero size thus invisible.

    Unfortunately, this theory does not explain why some people see new posts and edits to existing posts immediately after publishing/updating, while others don’t see it immediately. Besides, both <p font-size:0;> and <p font:12;> are simply invalid and the font-size specified would simply be ignored if the block is rendered as HTML instead of converting to a paragraph block (unless your theme or a plugin is doing some wacky stuff on your site).

    @mrm4: Are you able to temporarily turn off GoDaddy’s external caching for your site and TEST, just to see if this indeed is the problem?

    Admittedly I’m not with word press long but this worked. I changed the html and updated the default paragraph and my text was visible. Sorry it wasn’t a solution for you. I appreciate how frustrating it can be not having a solution to a problem with web design. Good luck right now that’s the only word press problem I’ve solved / run into so far.

    I logged in to my account and it says CDN is not yet enabled.

    I looked on the wp-admin of the site and saw an option to check cache. I clicked it and it says “No known cache service has been detected on your site.”

    I have a plugin installed called proxy cache purge. Could that be causing the conflict?

    Do you have the English link for that?

    @mrm4 https://www.godaddy.com/help/clear-your-cache-12444
    this link indicates that godaddy on managed wordpress uses a cache plugin and tells you that if you no longer find the plugin contact support. Furthermore the web cache service should be available only for users (pro of the united states and canada) at least this is what appears from the plan that you can subscribe.

    1) Enter the WordPress dashboard (http://yournameDomain/wp-admin/).
    2) At the top of the control panel, in the GoDaddy menu select Clear Cache.

    Thanks. I have done that before and the issue still persists.

    We have another site, also through GoDaddy, and we don’t have these issues with it.

    • This reply was modified 15 hours, 24 minutes ago by  MRM4.

    if I enter ?nocache=1 or without you don’t notice changes without your articles being cached. try the chrome incognito mode.
    I see all your articles even with the cache of the web server.

    I’ll have to tell all our readers to use that mode if they are using Chrome?

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.