Support » Plugin: Responsive Menu » Updates break your styles

  • This is a great plugin, but when you update it to the newest version, it totally breaks your old styling. And so…. you need to apply all the settings again.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Peter Featherstone

    (@peterfeatherstone-1)

    Hi Brian,

    I’m afraid that’s not true. From version 2.8.1 up to version 3.1.0 the settings are carried over.

    After 3.1.0 this was removed due to the fact that 2.8.1 is now over a year old so I can’t really be held accountable if people don’t keep their sites up to date in over a year.

    In addition, I gave a whole years notification period for this with notifications and webpages explaining it. I feel like I did all I can (including contingency strategies as described below).

    You can download version 3.0.1 which will automatically copy over your settings from the old version and then you can upgrade from there keeping your settings.

    I really wish you had asked me about this in the support forum first (thats why its there) rather than leaving a negative review as there are many ways to solve this very quickly.

    All the best

    Peter

    @peter, you wrote:

    “You can download version 3.0.1 which will automatically copy over your settings from the old version and then you can upgrade from there keeping your settings.”

    Could you provide a download link to version 3.0.1 please? I’ve been looking for it, but it seems I cannot find it anywhere anymore.

    Thank you very much.

    Peter Featherstone

    (@peterfeatherstone-1)

    Hey there,

    Sure. You can download it from the Advanced tab below:

    https://en-gb.wordpress.org/plugins/responsive-menu/advanced/

    Peter

    Thank you!

    It’s not working though. All settings are gone anyway (coming from version 2.8.9 and updating to 3.0.1). Even the breakpoint is not copied from my old settings.

    Looks like you changed some CSS classes as well, because my styling is not picked up anymore. So it seems I have to start all over again.

    Don’t bother though, I’ll look into this later. It’s unconvenient, but I’m sure I’m able to fix this.

    Peter Featherstone

    (@peterfeatherstone-1)

    Hey there,

    Had you already upgraded to a newer version before installing 3.0.1?

    You are correct about the classes. That’s why it was a major version change.

    Please let me know if you need any further help.

    Peter

    Peter Featherstone

    (@peterfeatherstone-1)

    Hey @idml

    Did you manage to follow the instructions and get this working for you yet?

    Peter

    @peterfeatherstone-1

    Yes, I did. I first upgraded to the most recent version, then got back to the old one because of the changes I didn’t expect. That’s why my settings are gone in 3.0.1 now, I suppose?

    Thank you for offering me further help. I will update the plugin in about two weeks or so, don’t have much time right now. Perhaps I’ll come back to you then.

    Thanks again!

    Peter Featherstone

    (@peterfeatherstone-1)

    Hey there,

    Yeah that would be the reason 🙁

    If you need any help in future please let me know.

    Peter

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Updates break your styles’ is closed to new replies.