• Resolved clarkag

    (@clarkag)


    Here’s a problem I keep running into.

    Every time Jetpack gets updated by my website, my Jetpack account gets disconnected and I get the message in the WP backend to “finish setting up my account”

    I am using Jetpack’s portfolio category to display my portfolio pages.

    The issue is that the portfolio pages aren’t available until I reconnect my Jetpack account. And then I have to purge my cache, etc to get the portfolio pages to display.

    How do I prevent this from happening?

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hi there,

    Can you tell us a little bit more about how Jetpack is getting updated? Are you updating manually? Do you have automatic updates for Jetpack activated in WordPress?

    Has this always happened when you update Jetpack or has it just started happening recently?

    Thread Starter clarkag

    (@clarkag)

    Hi Tracy!

    I update Jetpack manually.

    I do have the SG Optimiser plugin from my host, Siteground, which can auto-update the Jetpack if I set it to. I have not yet because of this issue.

    Yes this has happened ever since I started using the Jetpack portfolio pages a couple years ago.

    Thanks,
    Clark

    Plugin Contributor Jen H. (a11n)

    (@jenhooks)

    Hey Clark,

    Can you please contact us at the form I’ve linked here? Make sure to link this thread in your ticket.

    Thanks!

    Thread Starter clarkag

    (@clarkag)

    Hi Jen,

    I am not a paying customer so the form just gives me links to documentation.

    Do you have another contact method?

    Plugin Contributor Jen H. (a11n)

    (@jenhooks)

    That specific link should allow you to send us an email without being a paying customer. Can you try in a different browser? Thanks!

    Thread Starter clarkag

    (@clarkag)

    I think I was not logged in the first time. 🙂

    I sent the request using the form.

    Thank you!!

    Plugin Contributor Jen H. (a11n)

    (@jenhooks)

    Awesome, thanks. I’m going to mark this thread as resolved now. We’ll see you via email.

    Thread Starter clarkag

    (@clarkag)

    Update: I believe I was confused. Jetpack doesn’t disconnect when it updates, it disconnects after it’s been DISABLED and enabled.

    So what happens is when theres an issue with the site and a bunch of plugins are temporarily disabled, if I’m not paying attention then Jetpack remains disconnected after enabling it again. This often happens when a developer is hired to do the fixing. This disables all my portfolio pages.

    Here is a screen recording: https://share.getcloudapp.com/YEuQ5kmG
    You can see the Portfolio post types are available until I disable Jetpack, and then they’re still missing after I enable it again. I have to set up Jetpack EACH TIME I disable it.

    All my other plugins can be enabled without any issues whatsoever. Is this possible with Jetpack?

    • This reply was modified 3 years, 5 months ago by clarkag.
    Plugin Contributor Dan (a11n)

    (@drawmyface)

    Hi @clarkag

    Ok, that is actually expected behaviour. The Jetpack connection is broken when the plugin is deactivated, so you have to reconnect it after reactivating the plugin. If you need to deactivate Jetpack during troubleshooting, you’ll have to remember to reconnect it again after it is reactivated.

    Thread Starter clarkag

    (@clarkag)

    Alright then. Good to know.

    From a user point of view, you might want to consider somehow preventing the connection from being broken.

    Many other plugins have connections to accounts and can be safely turned off and on without breaking the connection each time.

    Cheers!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Updates Always Disconnect My Account’ is closed to new replies.