WordPress.org

Forums

Fast Secure Contact Form
[resolved] Updated Version 3.1.7.3 = PHP sessions are broken on this server (11 posts)

  1. passegua
    Member
    Posted 2 years ago #

    Just updated to version 3.1.7.3 :

    Cannot send contact form any more:PHP sessions are broken on this server

    Previous version working perfectly well.

    Please tell me how downgrade to previous working version.

    Many thanks.

    http://wordpress.org/extend/plugins/si-contact-form/

  2. passegua
    Member
    Posted 2 years ago #

    I'd like to add that the testing option is working.
    I can send a test message to myself in the options' page, so I don't understand why that "PHP sessions are broken on this server" message is coming up.

    Thanks.

  3. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    The error indicates that your server is unable to use php sessions. Php sessions are now a requirement of this plugin. the test an email tool is not a measure of this problem or not.

    The error is telling you that it cannot open the required session temporary folder because the folder does not exist or that the permissions or ownership is incorrect. This is purely a server misconfiguration, not a program error with the plugin.

    Solution:
    Make a trouble ticket with your web host. Ask them to fix the broken PHP session feature of the web server. It will better help them resolve the problem if you include the error message and a URL to your page with the error on it. They can create the proper temporary folder needed for PHP sessions. If the folder is already there, they can check and make the necessary adjustments to the folder permissions or group ownership. Then the sessions will work as they should.
    If you follow the instructions given at this page, you can use the upgraded version.
    http://wordpress.org/support/topic/how-to-fix-a-session_start-error

  4. passegua
    Member
    Posted 2 years ago #

    I opened a ticket with my host about php session temp folder.
    Meanwhile could you tell me which temp folder should I change permission to?
    Most of my folder have 755 permission, which should I change?
    Thanks.

  5. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    Session folders are not in your web site folders that is why a web host has to fix them. Sorry you are having trouble, i looked at your site and did not see the session errors that normally accompany this message. It is a possibility that the code to detect a session problem is not working as expected. I can assist you personally if you contact me here
    http://www.fastsecurecontactform.com/contact

  6. passegua
    Member
    Posted 2 years ago #

    Ok, thanks. I prefer waiting until my host will send me an answer to my ticket.
    I already wrote you personally since I'd like to send a revised Italian translation of .mo and .po files.
    Best wishes, d.p.

  7. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    The plugin has gone trough some bug fixing in the last few versions since version 3.1.7 when I had to restructure the code to fix for compatibility with JetPack, SFC Like, and other plugins that modify "The content".

    When version 3.1.7 came out, I had to require PHP sessions but it seems every 1 out of 3,000 users has a server with broken sessions.

    I worked almost all day today on a new approach to sessions that no longer uses PHP sessions, but an internal WP replacement. So hopefully the issue can be resolved for good.
    Will you test it?

    All you need to do is FTP to your server, and upload some files that I can send you.

    Fill out my support form and go ahead and ignore the donation request it asks for. Then I will send you the files to test.

    Mike

  8. bensitebuilder
    Member
    Posted 2 years ago #

    Hi,

    I was just wondering if I could request the test files as well? Getting the same error as passegua.

    http://s2.postimage.org/cbyctmkkp/Screen_shot_2013_01_30_at_9_44_49_AM.png

    The error appears in Safari but not in Chrome.

    Thanks so much,

    Ben

  9. db53
    Member
    Posted 2 years ago #

    Having the same issue

    I logged a ticket with host, and his reply
    (Website details deleted)

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at / / /public_html/wp/wp-content/plugins/better-wp-security/inc/secure.php:22) in / / /public_html/wp/wp-content/plugins/si-contact-form/si-contact-form.php on line 1925
    (from host ticket)
    The second line is involving sessions, the issue being that you have two plugins that conflict (better-wp-security and si-contact-form). You'll want to show this line to the developers of the plugins to see what they can do

    I disabled better security, but still get php error

    Hope this helps.

    Brett

  10. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    I will release a new version 3.1.8, try it.

    Mike

  11. db53
    Member
    Posted 2 years ago #

    All good Mike.

    installed update and working again, thankyou

    Brett

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Fast Secure Contact Form
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic