Support » Plugin: iThemes Security (formerly Better WP Security) » Updated, tried to re-activate and now getting locked out of site (SSL)

  • Resolved jennsweb


    I just did the update and now when I tried to follow the instructions and de-activate then re-activate the new iThemes plugin, I got the following message:

    Secure Connection Failed

    An error occurred during a connection to

    SSL received a record that exceeded the maximum permissible length.

    (Error code: ssl_error_rx_record_too_long)

    * The page you are trying to view can not be shown because the authenticity of the received data could not be verified.

    * Please contact the web site owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site.

    Prior to this, I had seen on the log that there had been 7 login attempts and someone had used 5.2mb of bandwidth to upload images. I don’t see any new images on the site, and i thought this may have been a backup of the theme.

    Here’s that message:
    A file (or files) on your site at have been changed. Please review the report below to verify changes are not the result of a compromise.
    Scan Time: Sunday, March 30th 8:52 pm UTC
    Files Added: 18
    Files Deleted: 0
    Files Modified: 0
    Memory Used: 5.28 MB
    Files Added

    Is this related to why the update crashed my dashboard?

Viewing 2 replies - 1 through 2 (of 2 total)
  • I also just experienced the same after updating a site from 3.6.6 to 4.0.7, i.e. that the site suddenly was trying to load wp-admin over https.

    My solution: Remove two SSL directives, that was added to wp-config.php.

    Hi Jakob,

    I did a little “due diligence” googling and this seemed to be the across the board answer to the issue. The two lines of code were at the top of the wp-config.php file and looked like this:


    Of course I saved the file as wp-configORIG.php on my hard drive before removing the code and then saving it as wp-config.php. Thankfully, this worked and I didn’t have to revert back!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Updated, tried to re-activate and now getting locked out of site (SSL)’ is closed to new replies.