Support » Fixing WordPress » Updated to WP 4.5, TinyMCE no longer working correctly

  • Resolved doncullen

    (@doncullen)


    Updated to WP 4.5, TinyMCE no longer working correctly.

    I can’t click on ‘Text’ to edit source code. I’m unable to use any of the toolbar options. Clicking on ‘Text’ tab or clicking on the toolbar options result in this error (as seen via console):

    wp-tinymce.php?c=1&ver=4308-20160323:12
    Uncaught TypeError: Cannot read property 'ownerDocument' of undefined

    Clicking on the link for wp-tinymce.php as given by console brings this up:

    var n = e.activeEditor;
                        n && t.target.ownerDocument == document && (n.selection && t.target != n.getBody() && (n.selection.lastFocusBookmark = c(n.dom, n.lastRng)),
                        t.target == document.body || d(t.target) || e.focusedEditor != n || (n.fire("blur", {
                            focusedEditor: null
                        }),

    With ‘t.target.ownerDocument == document’ being highlighted.

    I’ve reinstalled WP 4.5 along with all plugins being disabled, still the same problem.

    Suggestions on how to address this issue are appreciated.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Update:

    Checked my other blog, runs off its own copy (I have two installations, each on separate servers) — same problem here.

    I’m using Chrome version 50.0.2661.75 beta-m (64-bit).

    I went in WP-Admin using incognito mode (to ensure all browser extensions were disabled), disabled all WordPress extensions, then tried again to use TinyMCE. Still the same problem.

    Opened Firefox, tried again to use it, works fine, interestingly.

    I then went to other sites via Chrome and tried using TinyMCE (outside of WordPress), TinyMCE works fine like a charm. So it’s only within WordPress that it breaks.

    My working theory: something changed in Chrome or WordPress (or even both) that broke both abilities to work together.

    For now, I’ll just use Firefox to use WordPress Admin and Chrome for everything else.

    Update:

    Regressed WordPress’s copy of TinyMCE to the WP 4.4.1 version, as I recall it was working fine on that version. It still didn’t work, same error. So now I’m starting to think it was Chrome that updated and broke whatever WordPress TinyMCE needed to rely on to be able to work. Since it works fine on Firefox, I’m guessing it’s a browser issue.

    Filed bug report with WordPress and Chrome teams. Chrome team did not provide a link (no surprise there). WordPress bug report link is here:

    https://core.trac.wordpress.org/ticket/36545#ticket

    I have the same issue here. Vanilla WordPress 4.5 in Chrome 50.0.2661.75 beta-m (64-bit).

    When I attempt to switch to the Text editor, I receive:

    tinymce.min.js?ver=4308-20160323:11
    Uncaught TypeError: Cannot read property 'ownerDocument' of undefined

    Works fine in Firefox.

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    I can’t duplicate this with Chrome v. 50

    When you say “vanilla wp”, do you mean a fresh install, with no active plugins, running the twentysixteen theme?

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    It was suggested in this thread

    Visual Editor Broken – 4.5

    that it may be a caching issue in our browser. If you open a new incognito session, do you continue to have the problem?

    I was able to confirm that this issue is related to the version of TinyMCE packaged with WordPress 4.5.

    I replaced the existing TinyMCE files with TinyMCE 4.3.10 and everything works as expected.

    Could you guys switch to a default theme and see if it works after that?

    Also try to deactivate all the plugins to see if a plugin is causing this conflict.

    Thanks Hardeep. I’m already on a default theme with all plugins deactivated. As mentioned, updating to TinyMCE 4.3.10 fixed the issue.

    Just wanted to chime in that I am experiencing the same issue with Chrome and TinyMCE. And yes, switched to default theme, deactivated all plugins, etc. on a fresh install.
    Just updated Chrome yesterday and it does not play well with this version of TinyMCE at all. Have also had to switch to Firefox for the time being, but perhaps I will try reverting to an older version of TinyMCE

    @dannidar This bug is fixed in upcoming WP 4.5.1. Good news is that you can manually patch it on any current site running 4.5 by following these steps.

    In my case, I discovered it was Sucurri that made the visual editor (tinymce) not work after the update. Reverting hardening on the wp-includes seemed to do the trick. My visual editor is now working again.

    Since I’m the OP, just wanted to chime in and confirm what Joshua Fredrickson posted; just follow those steps and it’ll work fine. When I applied them a couple days ago, it was fixed. Marking this thread as resolved.

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    Make sure you report that here:

    https://wordpress.org/support/plugin/sucuri-scanner

    Same problem here on all my sites. Sucuri is not installed on all of them.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Updated to WP 4.5, TinyMCE no longer working correctly’ is closed to new replies.