Support » Plugin: PDF Embedder » Updated to v4.5 and PDF no longer displays

  • Resolved Trible

    (@trible)


    Help?

    Like the subject line states, I updated to v4.5 and the PDF no longer displays.

    Is there a fix?

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support WP-PDF Support

    (@wppdfsupport)

    Hi @trible,

    The recent update included a version update to the PDF.js library. This error comes up if you have a caching and/or minifying plugin on your site that has cached the previous version of the plugin scripts and now does not match with the updated plugin. To rectify this error, you need to clear the cache on the site and you should also clear the browser cache to allow the site to reload the scripts.

    To prevent this error from occurring again in the future, you would need to exclude the paths from your site’s cache and/or minifying plugin. Please see our FAQ for the specific paths for your version (free, Premium, or Secured) of the plugin: https://wp-pdf.com/kb/the-api-version-does-not-match-the-worker-version-error-on-update/. You may need to consult with the documentation for your caching plugin in order to determine where the exclusions need to be entered.

    Once you have excluded these paths, flush the cache and reload the page; the error should now be gone.

    If you are not using a caching tool on your site but are still seeing the error, the scripts maybe caching in your browser and a hard reload is required.

    Browser hard reload keystrokes:

    • Windows: Ctrl + F5
    • Mac/Apple: Apple + R or Cmd + R
    • Linux: F5

    If you have any other questions, please feel free to send an email to contact@wp-pdf.com as we may not see messages posted here to respond in a timely fashion.

    Emma

    Trible

    (@trible)

    @wppdfsupport I DID clear the cache before checking and have done so several time since. However, I did Deactivate the cache plugin and your PDF Embedder works perfectly.

    Have now contacted W3 Total Cache regarding this issue, so THANK YOU for letting me know of this, as I’m having same issue with yet another plugin… using the SAME cache plugin, on another website.

    • This reply was modified 7 months ago by Trible.
    Plugin Support WP-PDF Support

    (@wppdfsupport)

    Hi @trible,

    Thank you for the confirmation on the cache clearing process. The developers are investigating why this is occurring with caching tools and the previous method of excluding the scripts / flushing the cache is not working.

    In the meantime, if you roll back to version 4.4 of the PDF Embedder it will resolve the issue until we have a solution for the update (or leave the cache disabled temporarily).

    I will update you as soon as the I hear back from them.

    Emma

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Updated to v4.5 and PDF no longer displays’ is closed to new replies.