Support » Plugin: Adaptive Images for WordPress » Updated to v0.6.62 and all images broken

  • I had a problem with my blog being in a non-root folder in the past and you kindly supplied a quick fix for it at the time. I’ve just updated to the newest release and all images on my site are – again – broken (I’ve disabled the plugin for now, obviously).

    I did check and the code which I repaired last time is now completely different so the previous fix isn’t possible / relevant.

    Please find the debug info and diagnostics below. Cache directory and htaccess are apparently being created / written to with no problem.

    array(12) {
    [“resolutions”]=>
    array(3) {
    [0]=>
    int(1024)
    [1]=>
    int(640)
    [2]=>
    int(480)
    }
    [“cache-directory”]=>
    string(21) “cache/adaptive-images”
    [“watched-directories”]=>
    array(2) {
    [0]=>
    string(18) “wp-content/uploads”
    [1]=>
    string(17) “wp-content/themes”
    }
    [“jpeg-quality”]=>
    int(65)
    [“sharpen-images”]=>
    bool(true)
    [“watch-cache”]=>
    bool(true)
    [“browser-cache”]=>
    float(180)
    [“landscape”]=>
    bool(false)
    [“hidpi”]=>
    bool(false)
    [“cdn-support”]=>
    bool(false)
    [“version”]=>
    string(6) “0.6.62”
    [“sanitized”]=>
    bool(true)
    }

    Web Server
    Apache
    Document Root
    /var/www/vhosts/moshville.co.uk/Moshville
    PHP
    5.6.30
    PHP Time Limit
    30
    PHP Memory Limit
    256M
    PHP Post Max Size
    110M
    PHP Upload Max Size
    100M
    PHP Max Input Vars
    1000
    PHP Display Errors
    Yes
    PHP Error Log
    MySQL
    5.6.35-log
    MySQL Ext/mysqli
    Yes
    MySQL Table Prefix
    wp_moshville_
    MySQL DB Charset
    utf8
    WP
    4.7.3
    WP Multisite
    No
    WP Debug Mode
    No
    WP Site url
    http://www.moshville.co.uk/wordpress
    WP WP Home url
    http://www.moshville.co.uk
    WP Permalinks
    /%category%/%year%/%monthnum%/%postname%/
    WP home path
    /var/www/vhosts/moshville.co.uk/Moshville/
    WP content dir
    /var/www/vhosts/moshville.co.uk/Moshville/wordpress/wp-content
    WP plugin dir
    /var/www/vhosts/moshville.co.uk/Moshville/wordpress/wp-content/plugins
    WP content url
    http://www.moshville.co.uk/wordpress/wp-content
    WP plugin url
    http://www.moshville.co.uk/wordpress/wp-content/plugins
    WP Locale
    en_GB
    WP Memory Limit
    128MB
    WP Max Upload Size
    100mb
    WP Active plugins
    ManageWP – Worker v.4.2.16 by ManageWP
    WP Missed Schedule v.2014.1231.2016.1 by sLaNGjI’s Team
    Adaptive Images for WordPress v.0.6.62 by Nevma
    Advanced Random Posts Widget v.2.1.0 by Theme Junkie
    Akismet Anti-Spam v.3.3 by Automattic
    Amazon Link v.3.2.6 by Paul Stuttard
    Autoptimize v.2.1.0 by Frank Goossens (futtta)
    Comet Cache v.170220 by WebSharks, Inc.
    Crop Thumbnails v.0.10.12 by Volkmar Kantor
    Edit Flow v.0.8.2 by Daniel Bachhuber, Scott Bressler, Mohammad Jangda, Automattic, and others
    Enable Contributor Uploads v.1.0 by Road Warrior Creative
    Facebook Thumb Fixer v.1.6 by Michael Ott
    Flickr Badges Widget v.1.2.9 by zourbuth
    GA Google Analytics v.20161116 by Jeff Starr
    Simple Calendar v.3.1.9 by Moonstone Media
    GTranslate v.2.8.15 by Edvard Ananyan
    iframe v.4.3 by webvitaly
    Jetpack by WordPress.com v.4.7.1 by Automattic
    Responsive Flickr Slideshow v.2.4.1 by Robert Peake
    New Google Plus Badge Widget v.1.1.2 by MyThemeShop
    Social Login v.5.2 by Claude Schlesser
    PHP Compatibility Checker v.1.4.0 by WP Engine
    Fast Secure Contact Form v.4.0.50 by Mike Challis, Ken Carlson
    Simple Flickr Set v.1.0 by Scott A. Williams
    Simple Lightbox v.2.6.0 by Archetyped
    Slickr Flickr v.2.5.4 by Russell Jamieson
    Stout Google Calendar v.1.2.3 by Matt McKenny
    Cookie Consent v.2.3.2 by Catapult_Themes
    WP Ajax Search Widget v.1.1 by Scott Evans
    WP Embed Facebook v.2.1.10 by Miguel Sirvent
    WP Mailto Links – Manage Email Links v.2.1.6 by Victor Villaverde Laan
    WP User Avatar v.2.0.8 by flippercode
    Comments – wpDiscuz v.4.0.6 by gVectors Team (A. Chakhoyan, G. Zakaryan, H. Martirosyan)
    WP MU plugins
    ManageWP – Worker Loader v. by ManageWP

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Takis

    (@nevma)

    Hello, my friend,

    In this version we tried to fix that previous problem, so that everything would work without needing any manual code changes.

    Did you try to simply re-save your Adaptive Images settings? This should be all that it takes in order to fix the problem. Could you please do this and let me know? (Also, try to always clear your cache and refresh with Ctrl+F5 when testing.)

    This has been a pretty peculiar case for us, because it was very hard to be able to resolve the actual WordPress directories from the requested urls and actually do this for all scenarios. I am terribly sorry for the inconvenience, but I think we will have eliminated the problem once and for all after this.

    Cheers,
    Takis

    Hi, Takis, and thanks for the response.

    All I did was run the update within WordPress for the plug-in. As soon as it had updated, the image links were broken. I have cleared the plug-in’s cache, my browser cache and done a “force refresh” on several browsers – all have the same result, the image links are broken.

    I have tried re-saving the settings also. Same result 🙁

    Plugin Author Takis

    (@nevma)

    Hello, my friend,

    This is pretty strange, because this is the exact case that we tried to solve with this update and we have tested it against many conditions.

    Can you please confirm that you are using this technique https://codex.wordpress.org/Giving_WordPress_Its_Own_Directory in order to achieve what we are talking about?

    Also, could you please send me the part of your htaccess file that the Adaptive Images plugin has produced?

    (I know you have to go in much trouble switching the plugin on and off, but I would really like your help in order to debug this!)

    Cheers,
    Takis

    I can confirm the issue: I use Adaptive Images on three different websites, all running on Apache and PHP 5.6. With the latest update (0.6.62), the images all over the websites are broken.

    When trying to open one of said images in a new tab, the message “Original image not found or not available” is displayed.

    Saving the plugin settings does the trick though, no need to clear the plugin cache on my setup.

    All WP installations are in the root folder.

    Plugin Author Takis

    (@nevma)

    Hi, @emabartolomucci,

    Thank you for your input, indeed this is a known issue that we could unfortunately not avoid!

    However, re-saving your settings should only be necessary in two cases:

    a) your WordPress is literally in a directory, like /blog, and your url has this directory at the end of it, like http://www.site.com/blog and

    b) your WordPress is virtually in a directory, like /wordpress, but your url does not ahve this directory at the end of it, like http://www.site.com/.

    Cheers,
    Takis

    Takis – no problem, a shame not as many plugin authors are as attentive 🙂

    For giving WP its own directory, I have checked my .htaccess and the appropriate lines I have are similar to those in the Codex document (though not identical). I set the site up several years ago so perhaps things have changed? The ones I have in place are:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Adaptive Images adds the following:

    # BEGIN Adaptive Images
    #=======================
    
    <IfModule mod_rewrite.c>
    
        RewriteEngine On
    
        # Watched directories
        RewriteCond %{REQUEST_URI} /wordpress/wp-content/uploads [OR]
        RewriteCond %{REQUEST_URI} /wordpress/wp-content/themes
    
        # Redirect images through the adaptive images script
        RewriteRule \.(?:jpe?g|gif|png)$ /wordpress/wordpress/wp-content/plugins/adaptive-images/adaptive-images-script.php [L]
    
    </IfModule>
    
    # END Adaptive Images

    Oh – I’m looking at that and thinking I *may* have spotted something:

    RewriteRule \.(?:jpe?g|gif|png)$ /wordpress/wordpress/wp-c....

    Pretty sure there’s an extra “/wordpress” there.

    Yes – activated Adaptive Images, edited .htaccess and removed the superfluous “/wordpress” and it works fine 🙂

    Ah, wait…

    Once I do that, the site works fine but every time I go to the dashboard in WP I get a red alert at the top of every screen:

    Adaptive Images Error — The .htaccess file is not updated
    The Adaptive Images settings are saved, but the .htaccess file was not able to be updated yet.
    Please try to save the plugin settings once again in Adaptive Images Settings. If the problem persists, then you should contact your system administrator and inform them about the issue.
    The .htaccess file permissions are: /var/www/vhosts/moshville.co.uk/Moshville/.htaccess => -rw-r--r--.

    If I then go to the settings and save them, the original Adaptive Images code is added to .htaccess *but doesn’t replace the edited section*. That is, I end up with two copies of the settings in .htaccess and the most recently saved one seems to overrule my edited version and the site breaks again 🙁

    Plugin Author Takis

    (@nevma)

    Hello, @iainpurdie,

    Thank you so much for go into all this trouble! Of course the double /wordpress is wrong. You were right to observe and correct this. We must find out how this came to be!

    In your case the plugin should have taken care of this in the first place by its own. I think that -somehow- the Adaptive Images plugin is confusing the htaccess file in your top-level directory with the htaccess file in your actual WordPress directory.

    Now, something must have changed since the first time you setup your WordPress installation to be in a subdirectory. According to the Codex your top-level directory access file should look something like this:

    <IfModule mod_rewrite.c>
        RewriteEngine on
        RewriteCond %{HTTP_HOST} ^www.mysite.com$
        RewriteCond %{REQUEST_URI} !^/wordpress/
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteRule ^(.*)$ /wordpress/$1
        RewriteCond %{HTTP_HOST} ^www.mysite.com$
        RewriteRule ^(/)?$ wordpress/index.php [L] 
    </IfModule>

    Are you sure that this is exactly your case?

    Cheers,
    Takis

    Takis,

    Apologies for taking so long to respond – it has been one of those weeks!

    Yes, I spotted in the codex when I was looking that my htaccess file script didn’t match. However, this is what’s been in use for years, now.

    I changed my script to the “new” version (obviously changing the “mysite” references) at which point the only page which would load became my index/home page. Every other page gave a “The requested document was not found on this server” error.

    I can only assume that the way WordPress handles subdirectories has changed over time and we’re still using an updated version which relies on an older system 🙁

    Plugin Author Takis

    (@nevma)

    Hello, my friend,

    I am afraid we do not have much choice left. If changing your WordPress subdirectories setup breaks your urls, then the only thing that we could do is require you to manually edit your htaccess file, each time the Adaptive Images settings are saved. It is obviously only a by-pass to the problem.

    Perhaps, sometime in the near future, after some major reconstruction or upgrade your website setup will become in sync with the Codex’s subdirectories norms.

    I am just sorry that our plugin did work nicely for you so far and now you have to go through all this. If you have any other ideas how we could debug this (a demo/staging installation perhaps?) I would be glad to hear them.

    Cheers,
    Takis

    Takis,

    As always, I appreciate your feedback! A manual change isn’t the end of the world and we’ll see if I can get it working that way – the only annoyance is Adaptive Images “nagging” me within WordPress as it doesn’t think the changes have been made!

    We’re looking at moving servers sometime in the near future and when we do it could be an opportunity to do a fresh install rather than just copying over. At that point, I think we’ll be sorted.

    Cheers!

    Iain

    Plugin Author Takis

    (@nevma)

    Hello, again,

    Aaah, yes that annoying error message. You are right about that, we have had complaints from other users as well and we intend to fix it as well. Initially we thought that the user really *had* to know about this message, because it is supposed to be crucial whether a plugin that controls your image delivery actually works or not. However, it does seem be a bit annoying in such cases.

    Please, do let me know if everything works out in the future, after you make any major changes. Feel free to contact at info [at] nevma [dot] gr, if you wish.

    Cheers,
    Takis

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Updated to v0.6.62 and all images broken’ is closed to new replies.