WordPress.org

Support

Support » Plugins and Hacks » WP eCommerce » [Resolved] Updated to latest version admin panel crashed

[Resolved] Updated to latest version admin panel crashed

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Justin Sainton

    @justinsainton

    How odd – someone else reported this as well.

    If you look at the actual code though – that’s inside a function that hooks into ‘pre_get_posts’. Looking at the Codex article for get_current_screen(), it should be safe to run on any hook after admin_init (pre_get_posts fires much further down the line).

    Can you give us any other information about other plugins you have running? If you can revert to the default WordPress theme and deactivate all other plugins – that might be a helpful step in resolving the issue.

    i renamed my theme folder in order to revert back to twentyten. I can no access admin panel,

    other plugins running:

    anyfont
    revolution slider
    visual composer

    i have also posted in my themes support forum, waiting to hear back.

    I upgraded to the new version and experienced the same thing as well. The site was up for website visitors but the entire WP Admin site has crashed with the same error. I had to ftp into the site, and delete the WP e-commerce directory under /plugins/ before I could log back into WP Admin.

    Fortunately we are still building the site and don’t need the ecommerce functionality yet. Please advise when the issue has been resolved.

    Using the Alyeska theme. Plugins: Akismet, Fast Secure Contact Form, Google XMl Sitemaps, Spammer Blocker and StatPress. Running latest 3.5.2 of WP.

    I’m having the same problem too.

    Plugins: adsense-made-easy, akismet, all-in-one-seo-pack, contact-form-7, content-aware-sidebars, content-slide, display-widgets, easing-slider, google-analytics-for-wordpress, google-sitemap-generator, jquery-slider, randomtext, search-everything, share-this, simple-tags, slider-pro, strx-simple-sharing-sidebar-widget, sugar-slider, vslider, wp-db-backup, wp-e-commerce, yet-another-related-posts-plugin

    This happened to me today. Actually this ecommerce plugin has created many problems for us. Does anyone have a a fix for this.

    reverted back to 3.8.11.1 via FTP and I am back up and running, Hopefully this will get sorted out soon!

    Link to previous versions of wp e-commerce: http://wordpress.org/plugins/wp-e-commerce/developers/

    Oh boy, why didn’t I think of that? Thanks for the fix!

    jmusgrave,

    Thanks for the tip!

    I had the same problem after updating the wp-ecommerce plugin. My wp-admin wouldn’t come up, but the site was ok. When we disabled the plugin wp-admin worked, but the site went down! We reinstalled the plug-in which crashed wp-admin again but at least the site is functional. Later today I will get some more help to reinstall the 3.8.11.1 via FTP as you suggested.

    Any news on an update that fixes this issue?

    Plugin Author Justin Sainton

    @justinsainton

    Hey guys,

    I’ve tried to replicate the issue in as many environments as possible (Outside of the obvious situation of an old version of WP where the function actually doesn’t exist) – I’m still not able to replicate it.

    If anyone is currently running 3.8.12 with a whitescreening admin, I’d be happy to help debug and see if we can find a solution. Email me with a set of admin credentials at justinsainton at gmail dot com.

    Hi Justin, I just emailed ya.

    Plugin Author Justin Sainton

    @justinsainton

    Thanks Bryan, that was really helpful.

    For everyone experiencing this issue, if you’re able to edit the plugin, open up the /wpsc-admin/display-items.page.php file, go to Line 490, and modify it to look like this

    if ( ! is_admin() || ( defined( 'DOING_AJAX' ) && DOING_AJAX ) || ! $query->is_main_query() )

    That should fix your issues. In fact, that was in our master branch on GitHub about a month ago – so I’m still a bit baffled at how we missed it in the 3.8.12 release – also baffled as to why some people experience this, and others (myself included) do not.

    Either way, that fix should do it for you! Let me know if it doesn’t.

    Thanks for the superior work Justin!

    Thanks Justin! Great Job!

    WordPress version: 3.5.2
    WP e-Commerce version: latest as of date (9th July 2013)
    Gold Cart version: N/A
    Theme: Akita

    I have tried applying your fix, Justin, but alas, the admin panel remains resolutely crashed.

    Site itself is unaffected.

    I remove the ecommerce folder, admin panel returns. Replace, crashes.

    Are there any other suggestions out there please?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] Updated to latest version admin panel crashed’ is closed to new replies.
Skip to toolbar