Support » Fixing WordPress » Updated to 5.0 but I don’t see the gutenberg editor

  • Resolved batracy

    (@batracy)



    After updating my site to 5.0 this morning, everything is still running and working fine with one small exception; The classic editor is still there! I’ve looked everywhere for a setting or any way to turn on the new editor and cannot find it. Still the old editor and it doesn’t look like anything changed except to say I’m running version 5.0.

    Did I do something wrong? Is this what was supposed to happen?

Viewing 10 replies - 1 through 10 (of 10 total)
  • lisa

    (@contentiskey)

    1-is classic editor plugin activated?
    2-do you see “classic editor” block on existing pages and posts?
    3-what happens when you create a new page or post?
    4-did you previously have the gutenberg plugin installed + active?

    • This reply was modified 5 days, 20 hours ago by  lisa.

    1-do not have classic editor plugin installed
    2-post and page editing looks exactly the same as it always has.
    3-same old “classic” editor is there
    4-no

    Moderator t-p

    (@t-p)

    Please review this post and attempt the basic troubleshooting suggested therein: https://wordpress.org/support/topic/read-this-first-wordpress-5-0-master-list/?view=all

    Have already been through the list, cleared cache, restarted. I can’t change the theme without totally breaking my site. I’ll set up a staging site and change the theme there to see what happens.

    Moderator t-p

    (@t-p)

    If you can install plugins, install “Health Check”: https://wordpress.org/plugins/health-check/ On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    Health check says it’s all good. Used the troubleshooting tab and enabled plugins one at a time, no problems. New editor was available. Enable my theme, new editor disappears and back to classic editor. So it would seem the problem is my theme.

    FYI, my theme is the PhotoMe theme.

    Thanks for the help.

    Moderator t-p

    (@t-p)

    Apparently your theme is not compatible with Gutenberg.

    For pro or commercial product support please contact the author directly on their site.

    Commercial products are not supported in these forums.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    If you are using a site with custom post types, then those post types probably don’t have the support for the new editor turned on.

    The new editor is active for Posts and Pages by default. It won’t show up for other things added by third parties, unless they have specifically coded to allow it.

    Thanks for marking this resolved. I forgot to do that. Many thanks for the help.

    Moderator t-p

    (@t-p)

    You are welcome 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.