Support » Fixing WordPress » Updated to 4.9, won’t detect page template…

  • Resolved connorlacombe

    (@connorlacombe)


    Hey all,

    This may just be an issue on my end, but I’m running out of ideas.

    Working on a theme, updated to 4.9, and now I can’t get WP to detect when I create a new page template file in the theme’s directory.

    The page templates I had prior to updating are still showing up when I check the page attributes dropdown, but any new templates won’t show up.

    Tried making a new page template on 4.8.3 on a different WP install, and it worked fine.

    Check file permissions and they all appear to be right. Is anyone else running into this issue?

Viewing 15 replies - 1 through 15 (of 17 total)
  • Update: Just deleted “_transient_files_xxxxxxxxxxx” (x’s are a hash of some kind) and the page template is appearing now. Still not sure why it’s doing this though.

    Moderator Marius L. J.

    (@clorith)

    Hiya,

    That’s a cached list of template types (just so we don’t have to scan your theme directory all the time), after a while it should have cleared out on its own and would have grabbed a fresh list of files.

    me either I tried to create a new page template but it is not showing on drop down.. can you guys let me know how to fix this? thanks a lot

    how can I clear that cached list of template types?

    Melster777 my provisional solution was open new private window.

    I wait for almost 1 hour it does not clear.. so I decided put back the old version.. now I can see the new page template that I created.. hopefully this will fix soon

    Having the same issue. A method to switch this cache on/off, would be ideal. Private window method doesn’t work for me.

    Moderator Marius L. J.

    (@clorith)

    We’re tracking this in a core ticket at https://core.trac.wordpress.org/ticket/42573, what will be the outcome I can’t say though, so I encourage you to watch the ticket (don’t post me-too’s though, we have a button to watch it and be notified if you’re interested 🙂 )

    I’m going to tag this one resolved, just for sanity sake so we know there’s a ticket for tracking instead which is more appropriate at this stage.

    Thanks Marius!

    If any theme developers are interested, I quickly put together a plugin that’ll add a “Clear File Cache” button to the admin bar: https://github.com/connorlacombe/WP-Clear-File-Cache

    Thanks Connor for that plugin. This is a frustrating issue that sent me diving into all sorts of potential issues. Hope they resolve this quickly.

    Thank you, Connor, for that plugin!!!

    I didn’t think of a cache but it makes sense because I was getting debug errors where it was unable to stream a page template I deleted an hour before. Switching themes back and forth cleared that out I was really stuck on getting new Templates to be recognized. I could change the name of an existing, but it wouldn’t find a new one.

    Thanks connorlacombe Your plugin saved my time. I don’t know why wordpress is doing this. This update wasted my time. I have a deadline and I am already late due to this. Thanks Man I just cleared the file cache and page template showing now.

    redsalmon

    (@redsalmon)

    Thanks Connor, that helped a sore head taking any more bangs. Deliberately breaking functions.php also clears template cache but much nicer to have a button.

    I kinda understand the cache intention if it speeds up admin but as others say an on/off button for it would be v useful.

    I’ve also found that if you update the Version of your style.css file it will clear the cache as well.

    Thanks a lot @connorlacombe your plugin saved hours of pain

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Updated to 4.9, won’t detect page template…’ is closed to new replies.