Support » Plugin: Cerber Security & Limit Login Attempts » Updated to 4.7.7 and reCAPTCHA broke

  • Hi there. I recently updated WPCerber to 4.7.7 and it broke my reCAPTCHA. I could no longer login at all (it would just keep saying I wasn’t human). I disabled WPCerber plugin, refreshed my browser and was logged in automatically.

    Checking out the new settings for reCAPTCHA, I tied disabling and reenabling it, I tried generating new keys form google, and I tied both the visible and invisible methods using proper keys from google.

    Each time, I get the message “ERROR: Request to the Google reCAPTCHA service failed” on the WPCerber reCAPTCHA settings page. It worked fine before the update, and recaptcha is working fine in Ninja Forms plugin which has its own reCAPTCHA config.

    In case its relevant, I am running WordPress on IIS/Windows on our own servers, and there are no restrictions to accessing the reCAPTCHA web service – as I mentioned, it works fine from another plugin and I can access it fine form web browsers on the server.

    Help?

    • This topic was modified 3 months, 1 week ago by  brandon.mol.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Gioni

    (@gioni)

    Hi!

    1. Could you tell me what exact version of the plugin did you have previously installed?
    2. Please make sure that cURLis enabled on your server properly.

    brandon.mol

    (@brandonmol)

    Looks like I had 4.1 installed.

    cURL is included with the windows/IIS PHP package – it appears to be present and activated in my extensions folder php.ini.

    Plugin Author Gioni

    (@gioni)

    In newer versions of the plugin the querying the Google reCAPTCHA service is performed by using cURL. So I think that in your case cURL is the source of the issue. I’ve updated the development version of the plugin and added code to display cURL error messages.

    Do the following:

    1. Install the latest development version of the plugin: http://my.wpcerber.com/downloads/wp-cerber.zip
    2. Enter correct reCAPTCHA keys and click Save Changes.
    3. If cURL generates some error, you see it as an error message.
    4. Show me error messages if you need further help.

    Plugin Author Gioni

    (@gioni)

    @brandonmol Hi! How is it going?

    Hi there. Sorry about the delay.

    I’ve tested out the 4.88 dev build you provided and I see no additional error messages in either the dashboard reCAPTCHA settings when I turn it on, or at the login prompt when trying to use it while it is turned on. The behaviour is the same as before.

    In case it helps, when attempting to login, I do get the advanced human detection feedback like having to select the images with cars in them or having to trace around a street sign. After doing that, the widget validates me as a human (I was wondering about that…) and then when I actually click to login it fails with this message (this is the same as before, by the way):

    ERROR: Human verification failed. Please click the square box in the reCAPTCHA block below.

    This… despite the fact that the human verification appeared to work fine (green check mark for normal I’m not a bot checkbox, or more advanced widgets working, etc…)

    Are there logs that I can send you?

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.