WordPress.org

Support

Support » Localhost Installs » [Resolved] Updated to 3.9 on local and now am getting fatal error, all pages blank

[Resolved] Updated to 3.9 on local and now am getting fatal error, all pages blank

  • Had 3.8.2, upgraded to 3.9.

    Now getting all blank pages and this in my error log.

    Fatal error: Call to undefined function wp_normalize_path() in C:\_APPLICATION\USCWEB\wp-includes\plugin.php on line 655

    Stack trace shows this as the last call: wp_register_plugin_realpath() C:\_APPLICATION\USCWEB\wp-settings.php:213

    Not sure what the issue is. Both of the files listed above are the updated version. Anyone else having this issue?

Viewing 15 replies - 1 through 15 (of 16 total)
  • Commented out lines 637-670 in wp-includes/plugin.php and line 213 in wp-settings and now I get an index page. still no dash.

    Disable all plugins and custom themes. Slowly re-enable them testing them one at a time until the issue appears. Inform the developer of said plugin/theme that was last enabled.

    Some plugins and themes have issue with the updated tinyMCE visual editor.

    Fatal error: Call to undefined function wp_register_plugin_realpath() in /websites/123reg/LinuxPackage22/fi/ne/tw/finetwork.co.uk/public_html/wp-settings.php on line 213

    getting the above error, an ideas, it has come from the upgrade to 3.9

    Ended up being ACF issue. I had updated the plugin but had forgotten I was using it inside of one of my own plugins as well. Solved.

    Hello,

    What is an ACF issue ?
    I’m having the same error “Fatal error: Call to undefined function wp_register_plugin_realpath() in /www/blog/wp-admin/plugins.php on line 150” when trying to activate some plugins…

    Any idea of what I can do ? Everything was working fine, I don’t understand what happened…

    Advanced Custom Fields. It needs updated to the most recent version. That being said as I went through the code I realized it could be a lot of different things. My advice would be start a fresh install and try again. Not great advice I know, but it’s what helped me find the issue.

    Thanks for your help !

    I am not even able to login to my dashboard. I did the same thing(updated with out backing up plugins) and now my account seems to be gone. Any help would be appreciated! – Russ Mock

    I had this same issue, I downloaded the latest 3.9 from wordpress.org and uploaded the wp-admin, wp-includes, and root directory files (except for wp-config.php of course). and then went to wp-admin and was asked to update the database. Once database was updated the site came back up and was running WordPress 3.9.

    BilliardGreg, would you mind posting instructions how to do that?

    BilliardGreg – brilliant, yes that solved the problem for me. Apparently the latest upgrade over do it from my current webhost, it went over the limit; so the plugin was not really the problem, nor any databse issues. Just the upgrade files could not be completed, so just nothing would work.

    makanakoho –
    1) Just upload the latest wordpress. Open the zip to folders etc.
    2) Connect to FTP.
    3) Over ride “wp-admin” folder/files; same with “wp-includes” from your new wordpress to your FTP.
    4) Over ride the main files (such as index.php etc). Dont over ride wp-config.
    5) log on now. May ask to upgrade the database; i would do a backup now just in case
    6) log on again, and that should be that.

    makanakoho, My apologies about not seeing what appears to have been an immediate request for instructions, and thank you rich_smc for clarifying for him. I didn’t notice the response and just came across it only because I went to my activity in my profile and wanted to see the last thing I posted. I had Notify me of follow-up posts via email turned off.

    my best thanks to rich_smc, i have solved problem on my website with your instruction.
    In fact, the problem arises precisely because the update is not completed, and it is enough to put the folder “wp-includes” for solve everything.

    Maurizio

    Just updated TO 3.9 and now receiving on all my pages…

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes) in /home/sderot/public_html/wp-admin/admin-header.php on line 173

    the pages on line seem to be fine I just can update them

    thanks rich_smc
    that worked

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] Updated to 3.9 on local and now am getting fatal error, all pages blank’ is closed to new replies.