Support » Fixing WordPress » Updated to 3.4.1 and now my categories no longer show, but return a 404 page.

  • Hi there,

    I have just updated to 3.4.1 and now my categories no longer work. When I click on any category it presents a 404 page listing all my posts.
    In the admin panel they are all there and nothing has changed. When I click on “View” in the category in the admin panel it shows the category perfectly as it should be, but not anywhere else. My static pages still work perfectly, it is only the categories that seem affected.
    If someone is able to shed some light on this for me I would be grateful. Please bear in mind that I am a newbie at this, so please try and explain this to me as simple as possible. Many thanks for any help in advance.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Sorry, I forgot to add my site: http://yoga-health-blog.com

    Update:

    Just discovered that when I add the word “category” to the URL in the browser it then shows the pages properly, without it it does not.

    This is what I mean:
    Returns 404: yoga-health-blog.com/yoga-articles/

    Shows it properly: yoga-health-blog.com/category/yoga-articles/

    Any ideas anyone?

    I now have located the problem. After I updated WP to 3.4.1 all my categories when visited returned 404 Page Not Found results. After many hours trying to figure it out, together with my host, it finally seems that every time I activate WordPress SEO the error occurs. Without it it works fine. Real bummer as I was a big fan of the plugin. Any suggestion how I can get this to work again?

    There are several WordPress SEO plugins . Just search for one that works well . It will mention if the plugin is tested with the current WP version

    I have version 1.2.5, the latest version and it worked perfectly until I updated WP to 3.4.1. After I figured out that it was WordPress SEO plugin that created the problems I went to their page here on WordPress.org and there I saw that most people have no problem with it, but 19 people had clicked on it saying that it was “Broken” since they updated to WP3.4.1, just like me.

    Are there other known plugins which will cause this same problem?

    I don’t use WordPress SEO, yet I’ve had the exact same failure since upgrading to 3.4.1

    It’s annoying enough that, security risks be ignored, I might have to revert to 3.4

    The only way to find out is to turn all plugins off and then restart each one separately until you find the plugin that gives you the problem.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Updated to 3.4.1 and now my categories no longer show, but return a 404 page.’ is closed to new replies.