Support » Plugins and Hacks » [Resolved] Updated to 3.0 – can't view or download – goes to page

[Resolved] Updated to 3.0 – can't view or download – goes to page

Viewing 15 replies - 1 through 15 (of 22 total)
  • It turned out that something in 3.0 was looping and exhausting the memory. The error message read: Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 523800 bytes) in /users/st-stephens.org/htdocs/wp/wp-includes/plugin.php on line 104. Our host doubled our memory, and I got the same result. I downgraded to the previous version and got back in operation. ??? Hope this helps someone.

    I had the same problem with version 3. the view option in the dashboard was taking me to an individual-strange looking page and the drop downs were having the save behavior, I have reverted the version and works now.
    I really like this plugin, I hope it gets fixed!

    Plugin Author Eric Mann



    Not sure what’s happening there. Can you provide more details regarding the WordPress and PHP versions on your server? Is there any chance I can get a copy of the error logs from when things broke?


    The dropdowns will no longer take you to the Publication landing page but will immediately open the publication instead as of version 3.0.1.

    The “individual-strange looking page” is a Publication landing page. Since I can’t predict what theme you have running on your system, the default landing page template is based on WordPress’ default theme (Twenty Twelve).

    You can replace the template by dropping a single-publication.php file in your theme root and styling it however you want. Take a look at the default template in /wp-publication-archive/includes/single-publication.php to see how the different Publication fields are being retrieved and used by PHP.


    I just upgraded to the 3.0.1 version of your plugin and only one of my view and download links works for the 96 items in the archive.
    whenever anyone clicks a download or view link all it does is take them to a publication landing page.

    what should I do? downgrade?

    if it helps my site is wocati.org

    reverted to the old plugin and it works fine.

    Hope this might be a clue to cause of the problem. (I have got the same problem since version 3 – 3.0.1, not being able to download.)

    I checked the pages html source code – the download and view links from two different installations. One using the old plugin (version and on using the latest (3.0.1) and found the following differences:

    Source code from the old plugin page:

    Source code from the new plug-in page:

    As you see the “wppa” are missing in the download/view links in the source code on the page using the latest plug-in version. May this be a cause to the problem?


    I add this information as well. The first one you asked for above:
    PHP version on server: 5.3
    MySQL: 5.1
    WordPress: 3.6
    Other Plugins activated:
    – Role Scoper 1.3.61
    – Theme My Login 6.3.8

    Would be very happy if this information could help you or anyone else to find the cause of the problem. I really appreciate the plugin and rather not want to use an old version if not necessary.

    Plugin Author Eric Mann


    Do you have pretty permalinks enabled, or are you using the default ?p=234 format?

    I am using the default ?p=234 format.

    But the absolute url of the file is used when uploaded and published (in the publication post form). This is also the settings I have used earlier, all the time.

    Plugin Author Eric Mann


    The point of the plugin is to make it so your end users don’t download the file directly from the absolute URL. The file is read from the absolute URL directly and is passed directly through the browser to the end user.

    Whether you use the standard link structure (?p=123) or a pretty permalink structure, the behavior inside the plugin is the same. But there is a bug with the standard link structure at the moment.

    Ok, and thanks for your answer! If I interpret your answer correctly I should enable pretty permalinks instead? I will try this.


    Thanks a lot again. I changed to pretty permalinks and now it works.

    i’m using WP Publication Archive 3.0.1
    theme name: Tisson
    in Permalinks i selected web URLs to be “Post name” instead of “Default”

    The Web Site

    Issue: after clicking on “Download”, the downloaded file is broken (0 kb
    also the same thing with “view” option, the paged opened empty

    keep in mind that the files are uploaded correctly and saved on the server and when typing its absolute URL which in the publication form in the backend, the files showed correctly in the browser

    the files type is PDF
    so what is wrong?
    Thanks for you help




    i do have the same issue with 3.0.1
    When i use standard permalinks it takes me to the publication page.

    I have changed from standard permalinks to pretty permalinks, and then i get a 404.
    I see that some of the websites posted before already solved the problem. did everybody just downgrade to a previous version?

    It’s hard to believe this is the only solution?

    my site: http://tiefenoekologie.at/?page_id=511

    or http://tiefenoekologie.at/ressourcen

    i appreciate your help.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Resolved] Updated to 3.0 – can't view or download – goes to page’ is closed to new replies.