WordPress.org

Support

Support » Installation » Updated to 2.7.1 but stills notice me of a new update

Updated to 2.7.1 but stills notice me of a new update

  • Hello

    I’ve updated manually from 2.7 to 2.7.1 and WP stills notices me about a new upgrade possible.
    When I click to automatic update, it downloads, uncompress and then nothing more.

    Anything missed ?

    Thank you 🙂

Viewing 15 replies - 1 through 15 (of 18 total)
  • Hi,
    I have the same experience : manually upgraded to 2.7.1, and still got the notification I need to upgrade. In the dashboard, I got the “You are using WordPress 2.7.1” message along with “WordPress 2.7.1 is available! Please update now” 🙂

    Also, I have upgraded some plugins ; and got the same notification issues.

    Nicolas

    Same here, I just did a manual upgrade and it’s not recognizing it. Still telling me to upgrade to 2.7.1.

    Anyone know what’s up with this?

    Figured it out. I downloaded 2.7.1 from the link inside the admin panel, but on closer inspection it was not 2.7.1 but just 2.7. (I looked at the code of a few files to see if the changes were actually there.) So I actually just swapped the same files. I wonder if there’s a problem with that download link in the admin panel.
    Trying it again now with the real 2.7.1 downloaded directly from wordpress.org

    Just completed the manual upgrade with the real 2.7.1. No issues. Problem solved.

    I’ve tried the “manual” solution, with 2.7.1 FR and stills told me to update 🙁

    I updated to 2.7.1 manually, verified $wp_version = ‘2.7.1’, but the upgrade banner still displays.

    What is even more annoying is that on the dashboard, in the Right Now panel, I see this message “You are using WordPress 2.7.1.” and immediately to the right of it is the button “Upgrade to 2.7.1”.

    I also upgrade Reveal ID plugin but still get the notification to upgrade plugin.

    Any thoughts?

    Look in the wp-config-sample.php to make sure you really have the 2.7.1 files. (When I downloaded through the WordPress admin panel, it said 2.7.1 but it turned out to be 2.7). In that file, look for the link to the secret key generator. If that link starts with http://api… then you have 2.7. The change in 2.7.1 is to a secure page: https://api

    If you do have 2.7.1, then I can’t help you any further.

    I do not overwrite or re-create my wp-config.php file, but I added the “s” to the url string. I checked the changelog to verify that is the only change to the config file.

    I am sure I have 2.7.1, I downloaded it from wordpress.org/download and I checked version.php.

    I also looked at http://core.trac.wordpress.org/ticket/8729 which is kind of similar but I am using the English version. Also, this bug seems to be related to 2.7

    Any thoughts? And thank you for the help.

    This seems to be the problem. In wp_options database table, this value needs to change from:

    O:8:"stdClass":3:{s:7:"updates";a:1:{i:0;O:8:"stdClass":5:{s:8:"response";s:7:"upgrade";s:3:"url";s:30:"http://wordpress.org/download/";s:7:"package";s:40:"http://wordpress.org/wordpress-2.7.1.zip";s:7:"current";s:5:"2.7.1";s:6:"locale";s:5:"en_US";}}s:12:"last_checked";i:1234808103;s:15:"version_checked";s:3:"<strong><em>2.7</em></strong>";}

    to
    2.7.1

    I made the change manually, will this break things?
    Why would this field not update automatically?

    The update notification only checks a couple times a day (see here). Just guessing here, but if you’ve done a manual upgrade have you tried running wp-admin/upgrade.php since?

    Interesting, and maybe related, discussion just a day ago on wp-hackers:

    http://comox.textdrive.com/pipermail/wp-hackers/2009-February/024662.html

    Yes, I ran upgrade.php and the message was “No Upgrade Required Your WordPress database is already up-to-date!”

    If you want your blog to check right now for updates, you can delete the update_core option name record in your wp_options table. Note that plugins and themes each have their own check and update cycle, controlled by the records update_plugins and update_themes, in wp_options.

    I am also experiencing this problem. Just as caltman I am informed my version is 2.7.1 while the upgrade to 2.7.1 button is displayed. I also followed tobans advice and checked for the link to the secret key generator. Indeed i starts with https://api and so it should be 2.7.1.
    Aditionally i Installed wordpress yesterday and I used the following url: http://wordpress.org/latest.zip so I figgure it shouldn’t be possible for me to have anything older than 2.7.1.
    Should we just ignore the false upgrade notification?

    I don’t like how the new install writes folders to
    your server which cannot be deleted.

    WTF?

    – –
    Okay,
    Father Luke

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Updated to 2.7.1 but stills notice me of a new update’ is closed to new replies.
Skip to toolbar