Support » Plugin: iThoughts Tooltip Glossary » Updated to 2.6.4 and G icon is no longer showing in Editor

  • Resolved amberstarfire

    (@amberstarfire)


    I’m not sure if it’s directly related to this last update, but the G icon is no longer showing in the Tiny-MCE toolbar, and instead of showing the tooltips as a link in the editor, it is displaying the full shortcode. Would appreciate some help with this. Thanks.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Gerkin

    (@gerkin)

    Hi,
    It seems that the client-side script crashes.
    Have you recently updated WordPress to the latest version? Or made other plugins update?

    Hi Gerkin. We recently updated to 4.6. Not yet to 4.6.1.And yes, we’ve updated other plugins as well. I update one at a time and test the site. This problem did not come to light right away, so I’m not sure exactly when it occurred. I tried deactivating and then reactivating the plugin, but that didn’t help. Are you aware of which plugins might conflict with Tooltip Glossary? I can get a list of the plugins we use to you, but will have to wait until Monday.

    The strange thing is that we have our staging/test site, where the plugins have been updated and WP 4.6 – and don’t have this problem there.

    Amber

    Plugin Author Gerkin

    (@gerkin)

    Hi,

    Can you please open your browser console (ctrl+maj+i on Chrome on most platforms), open the pannel “Console” and copy/paste any error you find, if any?

    Thank you

    Hi Gerkin,

    Sorry this took so long. I couldn’t figure out what “maj” was … turns out I needed Ctrl-Shift-j. Anyway, here is what I found:

    JQMIGRATE: Migrate is installed, version 1.4.1
    http://sa01int001.fahw.com/intranet/wp-content/plugins/so-widgets-bundle/icons/typicons/font/typicons.woff?map0iz Failed to load resource: the server responded with a status of 404 (Not Found)
    http://sa01int001.fahw.com/intranet/wp-content/themes/customizr/inc/assets/css/fonts/fonts/fontawesome-webfont.woff2 Failed to load resource: the server responded with a status of 404 (Not Found)
    http://sa01int001.fahw.com/intranet/wp-content/themes/customizr/inc/assets/css/fonts/fonts/fontawesome-webfont.woff Failed to load resource: the server responded with a status of 404 (Not Found)
    util.js:208 Google Maps API warning: NoApiKeys https://developers.google.com/maps/documentation/javascript/error-messages#no-api-keys
    util.js:208 Google Maps API warning: InvalidKey https://developers.google.com/maps/documentation/javascript/error-messages#invalid-key
    VM45 extensions::schemaUtils:112 Uncaught Error: Invocation of form runtime.connect() doesn’t match definition runtime.connect(optional string extensionId, optional object connectInfo)

    Plugin Author Gerkin

    (@gerkin)

    Aw crap, a french word slipped in my sentence haha, really sorry about that

    Those messages are the only messages displayed when the G icon is supposed to appear?
    Can you please try using a different browser?

    Thank you

    Okay, so IE 11 is our company’s default browser at this time. When I open the console in IE, on the editor page, I see the following error:
    SCRIPT1046: Multiple definitions of a property not allowed in strict mode
    File: ithoughts_tt_gl-tinymce.min.js, Line: 10, Column: 616

    Interestingly, when I use chrome, the G and glossary icons appear.

    Hopefully, this will help.

    Amber

    Plugin Author Gerkin

    (@gerkin)

    Hi, thank you very much for those additionnal infos.
    So, to sum up (correct me if I’m wrong):

    • On IE, G & List icons are not shown. The browser console trow the error `SCRIPT1046: Multiple definitions of a property not allowed in strict mode
      File: ithoughts_tt_gl-tinymce.min.js, Line: 10, Column: 616`
    • On Chrome, buttons are shown correctly, but you have a bunch of outputs in the console

    My plugins are heavily tested only on Chrome/Chromium and Firefox, as those browsers tend to be the most up-to-date and with a uniform behavior. IE should work, in theory, but, as you reported me, there are some exception, that I’ll try to fix.

    Hi Gerkin. Yes, that’s correct. Thank you.

    Plugin Author Gerkin

    (@gerkin)

    Fix is ready, an update should be available in the next 10 days. Thank you for your report.
    Have a nice day 🙂

    • This reply was modified 3 years, 5 months ago by Gerkin.

    Hello Gerkin,

    First of all, let me say i really appreciate your plugin and i have been using it since a long time.

    Unfortunatelly, I encountered the same problem with my site https://tutovideo.ch/docs/lexique/

    Using:
    Wordpress v.4.6.1
    iThoughts Tooltip Glossary v.2.6.4

    The «G» icon doesn’t appear anymore in the editor and the tooltips are not working on pages…
    When I look in the Console, here is what it tells me:

    ithoughts-core-v3.min.js?ver=2.0.0:1 
    Uncaught SyntaxError: Invalid or unexpected token
    ithoughts_tt_gl-qtip2.min.js?ver=2.4.0:10 
    Uncaught ReferenceError: Ithoughts is not defined(…)
    (anonymous function) @ ithoughts_tt_gl-qtip2.min.js?ver=2.4.0:10

    Any idea how to fix this?
    Thanks for your help

    Pierre-Yves

    • This reply was modified 3 years, 3 months ago by gadlab. Reason: Giving version numbers of WP and plugin
    Plugin Author Gerkin

    (@gerkin)

    Hi,
    As I said in another thread, I was really, really busy last days for professional & personal reasons, so I wasn’t able to do anything.
    I believe that @gadlab ‘s problem is slightly different than @amberstarfire ‘s one.
    Anyway, I hope I’ll do a release very soon and ask you both if your problem is solved.
    Thank you for your patience

    Plugin Author Gerkin

    (@gerkin)

    Hi,

    v2.7.0 is out, can you tell me if it solve your problems?

    Cheers

    Thanks for the update…
    Ok… There is no more error message in the console, great job!

    Unfortunately the «G» icon didn’t re-appear
    Wysiwyg

    But ITG buttons are present in the html editor
    HTML editor

    Voilà, pour l’instant 🙂

    Plugin Author Gerkin

    (@gerkin)

    Hi,
    Are you using a TinyMCE customizer? And can you also try to clear your browser cache and retry? v2.7.0 had a huge refactor on resource files, maybe one was not updated in your browser…
    If you have the skills to do so, can you eventually check if /ithoughts-tooltip-glossary/js/ithoughts_tt_gl-tinymce(.min).js is loaded and executed? Maybe you could set a checkpoint in the middle of the file using your browser debug mode

    Unfortunately, I can’t do those checks by myself: everything works flawlessly on both my dev & prod environments. That’s why I need to have more infos on your config to understand why the f*** it works SOMETIMES. This drives me crazy.

    What browser & version are you using?

    Thank you for your comprehension. Have a great day, ami suisse 😀

    Yes, it was the browser cache. Everything is working fine now.

    Actually, the javascript library for TinyMCE is loaded several times.
    Once by the theme (“Salient” that uses Visual Composer) and once by your plugin.
    Do you think it could be a problem?

    Anyway, thanks a lot and keep up your great work.

    Ciao! Have a great day too! Dear French neighbor 🙂

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Updated to 2.6.4 and G icon is no longer showing in Editor’ is closed to new replies.