Support » Plugin: Simple Events Calendar » Updated to 1.3.3 and now the Events link is missing from the dashboard!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Additional information: I tried to hit the Events page manually, and WordPress returned You do not have sufficient permissions to access this page.

    There is no level I can find higher than Administrator, which is what my level is.

    Plugin Author Jerry G. Rietveld


    Hi sunshinebiker,

    With the latest update there have been no updates to the Privileges so if you’re definitely logged in as the administrator that shouldn’t be the problem.

    I’m not sure what the Members Plugin is that you’re talking about but to date I haven’t heard of any conflicting plugins.

    Could you maybe make a screenshot of your dashboard with the plugins section opened and share that? That might help me figure out what’s wrong.


    I don’t use the Members Plugin on this site, so it is not an issue here; was just trying to pre-think any questions you may have.

    Here is a link to the screenshot you requested:

    Plugin Author Jerry G. Rietveld


    Hi sunshinebiker,

    That’s a big list! I went through the names and I can’t see any names that could be conflicting on the basis of their names.

    Would you be able to check the following url while you’re logged into your wordpress dashboard:

    I see you’re running some plugins to customize the Admin area of WordPress so it could just be hidden but still be there.

    Let me know if that works or not. If not, I’ll install all the plugins that you’re running here locally and see if one of them might be conflicting.

    I deactivated all plugins except for Simple Events Calendar, and after that, the site still refused access to, saying that I do not have sufficient permissions to access the page.

    Also, the Events part of the navigation never appeared, which would be consistent with a permission issue.

    Plugin Author Jerry G. Rietveld


    Hmm… that message about insufficient access also appears when you try to open a non existing page.

    Could you open and do a search for SE_author. That will show you the level of authorization needed to manage events. If it’s only for administrators it should say manage_options.

    If it doesn’t show at all it means the plugin is not properly installed. You’ll see 7 lines starting with SE. The first one SE_author and the last one SE_twitter. If the plugin was updated correctly the SE_db_version should say 2.1.1.

    Does that all look good?

    Plugin Author Jerry G. Rietveld


    If all of that works, could you try the following:

    • Go to
    • In the pull-down menu in the top right corner select the plugin to edit: Simple Events Calendar
    • Check if there are 5 files that you can select from just below the pull-down menu
    • If you see 5 files, click on simple-events-calendar/simple-events-calendar.php
    • Search for function SE_menu()
    • In this function the menu is set. The line below starts with add_menu_page('Simple Events Calendar',
    • Find get_option('SE_author') in that function (same line) and change it to 'edit_posts'
    • Now check if that entire function looks like this:
      function SE_menu() {
      	add_menu_page('Simple Events Calendar', 'Events', get_option('SE_author'), 'simple-events', 'simple_events_options',SE_DOMAIN.'icon.png');
    • 2 lines below you see a function that starts with function simple_events_options()
    • Now make the same change in the line below. So In this line if (!current_user_can(get_option('SE_author'))) { change get_option('SE_author') to 'edit_posts'
    • Now check if that line you’ve just changed looks like this:
      add_menu_page('Simple Events Calendar', 'Events', 'edit_posts', 'simple-events', 'simple_events_options',SE_DOMAIN.'icon.png');
    • Do double check and if all looks good, save your changes.

    You’ve now hardcoded the authorization level to be the second lowest. If it was an authorization issue, the menu option should now reappear again.

    Thanks. This workaround has placed the Events button on the dashboard and it is functioning correctly. I assume I will need to save this code modification in the event an update to the Simple Events Calendar blows out this change.

    I can call this resolved. Thanks again!

    Plugin Author Jerry G. Rietveld


    Fantastic! Glad that worked!
    For future updates, you might have to apply this fix if the same issue happens again. But I will see if I can build in some sort of check for this.

    Could you do me a favor and let me know what you saw when you opened

    Especially for SE_author I would like to know if you saw that option in your list and what value it had.

    Thanks and again, happy we got this fixed!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Updated to 1.3.3 and now the Events link is missing from the dashboard!’ is closed to new replies.