Support » Theme: Sixhours » updated sixhours theme but child theme not working

  • Resolved pgb

    (@pgb)


    I have updated Sixhours but can’t use the child theme that I was using as the update is so different. I have made a new child theme, but it just doesn’t work. Below is my style.css, is it wrong?

    /*
    Theme Name: My Theme
    Description: Child theme for the sixhours theme
    Author: My Name
    Template: sixhours
    */
    
    @import url("../sixhours/style.css");
    
    #site-title a {
        color: #009900;
    }

    Should the Template name above be sixhours or Sixhours? I’ve tried both but it just doesn’t work.

Viewing 15 replies - 1 through 15 (of 18 total)
  • An update to the problem is when I try to activate my child theme, it doesn’t work. I then activate Sixhours but I get a message at the bottom of the Themes page ‘The parent theme is missing. Please install the “Sixhours” parent theme.’

    Bizarre! Has anybody else encountered this problem?

    Theme Author Caroline Moore

    (@sixhours)

    I tested your above stylesheet as a child theme and it’s working fine with my copy; the code is not working because it’s not targeting the right element. #site-title should be .site-title:

    .site-title a {
       color: #090;
    }

    If you’re unable to get the theme itself to work on its own, try reinstalling it before activating your child theme.

    (You may be using the above style as an example, and if so, disregard this advice. But if what you’re trying to do is change the color of the site title text, you can do that under Appearance -> Header, you don’t necessarily need a child theme at all.)

    Thank you Caroline. I was using the above style as an example. I have done as you suggest and reinstalled Sixhours, I even reinstalled my child theme but I still get the same message The parent theme is missing. Please install the “Sixhours” parent theme.

    Is there anything else to try?

    Many apologies!

    I have my child theme in place now. I had the template name as Sixhours, I have changed it to sixhours and everything is in place. I have no styles in my child theme style.css but neither has the website. It has not inherited the style.css of sixhours.

    Have I missed something?

    More apologies. I have made a child theme of twenty twelve and this has also not inherited the style.css of twenty twelve. Perhaps something is wrong with my WordPress 3.5 installation!

    Moderator Andrew Nevins

    (@anevins)

    Can you provide a link to your webpage that has the issue?

    PAVILLON ON TOUR!

    At the moment I am using the sixhours theme.

    I copied all the styles from sixhours style.css to my my child style.css but this did not work, there was still no styling, just html.

    Moderator Andrew Nevins

    (@anevins)

    I don’t see the problem http://awesomescreenshot.com/015r8vve1

    Thank you Andrew. I will leave the site on my child theme for about half an hour, for you to see. There is no styling.

    Moderator Andrew Nevins

    (@anevins)

    In the /wp-content/themes/ directory, is there a folder named ‘2012child’ ?

    Yes, that’s another child theme I made of 2012. That doesn’t work either.

    Moderator Andrew Nevins

    (@anevins)

    What is the folder’s name?

    jazz 2011

    Sorry it’s jazz 2013

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘updated sixhours theme but child theme not working’ is closed to new replies.