Support » Plugin: WooCommerce » Updated product details not displaying

  • Resolved petebm

    (@petebm)


    Hi

    I have a very curious problem that has defeated me entirely. We use Zoho Inventory, and update our products via a sync plugin. Recently, we’ve noticed that prices etc are not being updated on our website, and blamed the plugin. However, on closer inspection it seems they are being updated, but that change is seizing up somewhere in WooCommerce.
    So – if you could look at https://imgur.com/zRcEY8k, you can see that the summary product details for H4.12kit show the price as £428.55, as does the website. However, every other way of looking at it, via a bulk edit plugin, product details, or csv export, shows the correct (updated) price of £339.11.
    We have no caching plugins, Litespeed is disabled at our hosts, we don’t use variable products, sale prices – nothing out of the ordinary.

    Please, can someone work out why all those views show the correct new price, apart from the product listing &, vitally, the website!

    Thank you if you can, you might save me from more premature aging.

    Pete
    PS – I have now corrected the website by deleting the product entirely & letting the sync plugin re-create it from Zoho. That worked fine.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support RK

    (@riaanknoetze)

    Hi there,

    Just to make sure: Are you seeing the same thing after deleting transients using the WooCommerce tool under **WooCommerce > System Status > tools**?

    Hi

    Thanks for the incredibly quick response. You got my hopes up there, as I hadn’t thought of those tools, but I’ve now run through them all (deleted transients, updated the database, regenerated lookup tables) & still get the same.

    Sorry
    Pete

    Hi again

    Any more suggestions for this? The problem’s still happening, and after that seemingly perfect answer from @riaanknoetze (thanks), everyone’s gone very quiet . . .

    Fingers crossed!

    Pete

    Crossing my fingers seems to have had the desired effect, though not in the expected way.

    Checking the issue again today, I found that all the prices now match; the displayed price is now the same as that in the product properties. How, why or when this happened I have, unfortunately, no idea – but I’ll take it.

    Ah well.

    And like the traditional bad penny turning up, the problem’s back. Whether it ever entirely went away, I’m not sure – I may have just been ‘lucky’ in the products I checked. Either way, exactly the same thing is happening – the correct price for a product can be found everywhere except, crucially, in the overall product listing and the details page.

    If anyone out there has any ideas – bright or otherwise, I’ll try ’em all – please let me know.

    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.