Support » Plugin: Cart REST API for WooCommerce - CoCart Lite » updated plugin fatal error

  • Resolved jasperketone

    (@jasperketone)


    Hi I updated from 2.0.13 to 2.4 and I am getting fatal errors. Do I need to create this database table manually?

    Here is an example of one:

    2020/07/31 02:16:25 [error] 45947#45947: *21113402 FastCGI sent in stderr: “PHP message: WordPress database error Table ‘xxx.wp_cocart_carts’ doesn’t exist for query INSERT INTO wp_cocart_carts (cart_key, cart_value, cart_expiry) VALUES (’89c18980f76a3067229c046e5de34743′, ‘a:7:{s:4:\”cart\”;s:6:\”a:0:{}\”;s:11:\”cart_totals\”;s:367:\”a:15:{s:8:\”subtotal\”;i:0;s:12:\”subtotal_tax\”;i:0;s:14:\”shipping_total\”;i:0;s:12:\”shipping_tax\”;i:0;s:14:\”shipping_taxes\”;a:0:{}s:14:\”discount_total\”;i:0;s:12:\”discount_tax\”;i:0;s:19:\”cart_contents_total\”;i:0;s:17:\”cart_contents_tax\”;i:0;s:19:\”cart_contents_taxes\”;a:0:{}s:9:\”fee_total\”;i:0;s:7:\”fee_tax\”;i:0;s:9:\”fee_taxes\”;a:0:{}s:5:\”total\”;i:0;s:9:\”total_tax\”;i:0;}\”;s:15:\”applied_coupons\”;s:6:\”a:0:{}\”;s:22:\”coupon_discount_totals\”;s:6:\”a:0:{}\”;s:26:\”coupon_discount_tax_totals\”;s:6:\”a:0:{}\”;s:21:\”removed_cart_contents\”;s:6:\”a:0:{}\”;s:8:\”customer\”;s:691:\”a:26:{s:2:\”id\”;s:1:\”0\”;s:13:\”date_modified\”;s:0:\”\”;s:8:\”postcode\”;s:0:\”\”;s:4:\”city\”;s:0:\”\”;s:9:\”address_1\”;s:0:\”\”;” while reading upstream, client: 2a03:2880:20ff:5::face:b00c, server: xxx.com, request: “GET /?wc-api=wc_facebook_get_feed_data&secret=c8aa7322c82b6138ea015302f4920d9a HTTP/1.0”, upstream: “fastcgi://unix:/var/run/php7.3-fpm-xxx.sock:”, host: “xxx.com”

Viewing 1 replies (of 1 total)
  • Plugin Author Sébastien Dumont

    (@sebd86)

    Hi @jasperketone

    I was not able to replicate the installation issue when updating from v2.0.13 to v2.4

    It could be your WP installation did not reload correctly when reactivating CoCart.

    My only simple solution would be to deactivate CoCart, uninstall it and then re-install CoCart fresh with the latest release.

    If the table is still not created automatically after these steps then I will need a copy of your WooCommerce system status from you so that I can try and replicate the issue.

    Any additional details would be appreciated.

    Hope my solution works for you.

    If you have any questions please let me know.

    Thank you.

    regards,

    Sébastien.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.