Support » Plugin: Widget Logic » Updated: Logic lost? All widget logic statements got replaced

  • Resolved MrSlartibartfast

    (@mrslartibartfast)



    Hi Guys,

    First of, thanks for the plugin. I’m using it for a few years already and so far its the first time I’m having an issue.

    I’ve updated widget logic to the newest version: 5.8.1. (from version 5.7.something I think… maybe 5.7.4). Running on the latest wordpress version (4.7.5)

    Now I’m finding this code in all my widget logic fields:
    <?= esc_textarea( $logic ) ?>

    This appears also in previously empty fields.
    Strange enough the previous logic still seems to work at the moment…
    I’ve updated 3 websites – same result on all 3 (I’ve only noticed it on the last one, when changing something in a widget)

    Would be happy for any ideas what best to do.
    Cheers

Viewing 2 replies - 1 through 2 (of 2 total)
  • Same here, lost all logic statements …

    On further review, it seems server related.
    It happened to 2 sites which are on the same server, but not to some other sites on a different server. Al versions are 5.8.1.

    Hi again,

    Just a quick update:
    I haven’t found out what the reason for this is and its impossible for me to edit anything in the widget logic fields like this.
    any change, after pressing save, is replaced again with this code:
    <?= esc_textarea( $logic ) ?>

    The good news is that reverting to a previous version (5.7.4 in my case) worked and all my logic is back.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Updated: Logic lost? All widget logic statements got replaced’ is closed to new replies.