WordPress.org

Support

Support » How-To and Troubleshooting » Updated a page and now nothing is visible

Updated a page and now nothing is visible

  • I edited a Page – then when I went to save it sort of hung. Now nothing shows up/is visible – at all – on the site, except for the wp dashboard. No other admin pages are available (no error, just a big blank page) and no pages of the site itself. Again, not error messages, just big blank pages.

    I’m sure I did something stupid (I accidentally navigated away from the page when it hung upon saving) – but does one fix this?

    http://www.hudsonsedge.com/journal

    Any assistance greatly appreciated!!

Viewing 14 replies - 1 through 14 (of 14 total)
  • check your error log

    The only things I see are weird missing files – missing favicon, 404.shtml, robot.txt – etc.

    Nothing is related to this WP. (Also- interesting! I’ve never looked at that before! Thank goodness for Fantastico.)

    whooami

    @whooami

    Member

    you need to start by going back to the default theme.

    If you cant login to do it…

    http://hudsonsedge.com/journal/wp-login.php

    then access your files using an ftp client, and delete or rename the theme directory that corresponds to your current theme. You have the default theme available, so WP will load that one.

    http://hudsonsedge.com/journal/wp-content/themes/

    Done. I can now see all admin pages *except* the manage-pages sections. I’ve even made a new post hoping it would cycle through. Shall continue to tinker-

    whooami

    @whooami

    Member

    if you are sure that you are indeed using the default theme, and the site is still white, which it is (for me)… Insure that you arent using some caching plugin, if so clear that cache. and then systematically start disabling plugins and refreshing the front page.

    I tried renaming the index page to force it to create one- but that didn’t work either. Hmm- cache I know nothing of but I will look around.

    That’s what I get for updating the blog! *grin*

    whooami

    @whooami

    Member

    I tried renaming the index page to force it to create one

    huh? wordpress doesnt create any index.php
    Im giving you very specific directions, follow those instructions and you will be fine.

    The only plugins I use are spam karma2 (now disabled), email users (now disabled) and WPG2 which I heartily hate to disable because that is always a PITA to reset properly. I don’t use widgets.

    I’ve set and reset the theme, from classic to default to others and back to default, refreshing every time – nothing.

    I’m assuming at this point the only thing left is WPG2.

    whooami

    @whooami

    Member

    http://hudsonsedge.com/journal/error_log

    the error_log that is in the same directory as your wp-config.php, what does it say?

    I don’t see any error logs in that directory or any other. The only error log I know of is the one I can get to via Fantastico (I install WP thru that now as well).

    I have SmartFTP set to show me any hidden files- still don’t see anything like that.

    whooami

    @whooami

    Member

    if you like, I will take a look for you to see if I can figure out the problem — I would need access via ftp though.

    you dont have error_logs. your wp-includes directory is browsable, and there isnt one in there, and if I try to load one in my browser I get the same message.

    Assuming youre using the defualt theme, and all but the one plugin is disbaled, if it were MY site, I would turn on error reporting so that I got PHP errors.

    thats what I would do if I looked at your files.

    Hmm- now I see this:

    [Sat Jun 28 15:21:06 2008] [error] [client 66.41.253.36] File does not exist: /home/ksitton/public_html/403.shtml
    [Sat Jun 28 15:21:06 2008] [error] [client 66.41.253.36] client denied by server configuration: /home/ksitton/public_html/journal/.htaccess
    [Sat Jun 28 15:16:49 2008] [error] PHP Fatal error: main() [function.require]: Failed opening required ‘ABSPATHwp-admin/includes/admin.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/ksitton/public_html/journal/wp-admin/includes/upgrade.php on line 5
    [Sat Jun 28 15:16:49 2008] [error] PHP Warning: main(ABSPATHwp-admin/includes/admin.php) [function.main]: failed to open stream: No such file or directory in /home/ksitton/public_html/journal/wp-admin/includes/upgrade.php on line 5

    This was resolved, finally & immediately, by replacing the wordpress wp-config.php file from a fresh installation. No other problems since then.

    Well, make that unresolved- because I still get the same blank pages anytime I either edit or create a page (but regular posting is fine). This is all happening since the upgrade to 2.5.1 via Fantastico.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Updated a page and now nothing is visible’ is closed to new replies.
Skip to toolbar