Support » Plugin: WP to Twitter » Update with "Opt-In" notification ruined plugin

  • This plugin was functioning fine on our website for well over a year. With the most recent update, there is a notification to “Opt In” to provide data. NEITHER OPTION WORKS – i.e., you cannot opt in, you cannot skip. On top of this, it seems to be requiring a TON of resources to complete this process and has been crashing our database as a result. Unfortunately, we have decided to remove this plugin as a result. This plugin was GREAT for auto-updating a Twitter feed with posts. Hopefully they will address the bugs created with the last update.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Joe Dolson

    (@joedolson)

    It seems like Freemius may not be up to the load placed on it by WP to Twitter’s volume of requests; I’m communicating with the service to see whether this is resolvable or whether I’ll need to cut the service for now.

    Plugin Author Joe Dolson

    (@joedolson)

    Are you on the latest version of WordPress? I’ve just tested, and even with Freemius down, I don’t have any trouble skipping; that seems to work just fine. What happened when you skipped?

    Thank you for the update. When trying to “skip,” after a minute of loading, the Opt-In screen is simply reloaded. We are not able to get past that stage without choosing “Allow & Continue.” When we select allow and continue, we are taken to a Freemius error screen: Error 522 Ray ID: 2762dcb01ffb1816 • 2016-02-17 16:28:07 UTC
    Connection timed out

    Plugin Author Joe Dolson

    (@joedolson)

    Hmm. I’m not sure why that would happen. I’ve contacted the Freemius API developers with this issue to see if they have a specific idea about that. In looking at the code, it appears like this should function normally without API access, but I could be overlooking something.

    Hi @Villages-News.com,

    My name is Vova and I’m the lead dev of Freemius. First of all – sorry for the inconvenience. The skip should work and I’m more than happy to personally login to your dashboard, figure out what’s the problem and resolve it for you (without optin-in).

    Thank you for the follow-up. It does seem to be allowing “skip” properly and is giving us the ability to use the plugin. Thank you for addressing this. One question: Every time we leave the plugin and return to it, the opt-in screen appears. Will the opt-in screen be the default screen every time the plugin is opened now (unless we opt-in)?

    Plugin Author Joe Dolson

    (@joedolson)

    No, it really shouldn’t be; once you’ve skipped, the plug-in should always automatically shift to the normal settings screen when you go to it. Maybe Vova will have some insight there. It sounds like the method that sets anonymous mode isn’t functioning correctly.

    No – once you skip you should never see it again. If you are seeing a different experience, please contact me directly via [vova AT freemius DOT com] and I’ll help you to resolve it.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Update with "Opt-In" notification ruined plugin’ is closed to new replies.