Support » Plugin: Polylang » Update to YOAST SEO 9.4 makes language posts disappear

  • Hey guys,

    just wanted to file this bug report.
    I’m running a multilingual site using polylang – English and German.
    Everything worked fine until I updated YOAST to 9.4, which made all English language versions of all posts disappear (“nothing found”).

    Even though from the “posts” dashboard I could still see all the English post, and when I edited them, all the content was still there. Hitting “update” once again and then “view post” resulted in that empty blog post.
    So nothing was deleted from the backend, just not displayed on the front end.

    Posts in other languages (German) were not affected.

    Luckily, I had a backup of my site and restored it, not updating yoast this time.
    Can you please fix this issue as leaving yoast on the outdated version can only be a temporary solution.

    Thanks :)!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You should contact Yoast first. An update of their plugin produces the error. I can imagine you find the solution with them, as well.

    I had already contacted Yoast first, a few days before opening this thread.
    Following their very helpful tips, it turned out that the conflict is caused by the interaction of polylang with Yoast.

    As they suggested: “Please report the issue to a third party developer as well”.

    I hope the plugin author or someone else can give advice on how to make those two plugins be nice to each other again 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Update to YOAST SEO 9.4 makes language posts disappear’ is closed to new replies.