Support » Plugin: WooCommerce » Update to WooCommerce 3.3.5 not compatible with PHP 5.3

  • Resolved Tim Smith

    (@creativeinfusion)



    WooCommerce version: 3.3.5
    WordPress: 4.9.5
    PHP: 5.3.28

    Upgrading to WooCommerce 3.3.5 on PHP 5.3.28 generates a 500 Internal server error which is caused by an “End of script output before headers”, both on site front-end and in the admin.

    Deactivating WooCommerce fixes the problem.
    Changing to PHP 5.6 fixes the problem.

    Curiously once the WooCommerce database has been updated (using PHP 5.6), WooCommerce 3.3.5 will run happily in PHP 5.3.28 again

Viewing 1 replies (of 1 total)
  • Plugin Support RK

    (@riaanknoetze)

    Hmm, that’s an interesting oddity 🙂

    That said, please note that WordPress itself recommends a later version of PHP – it’s not down to WooCommerce’s preference. More information at: https://wordpress.org/about/requirements/

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.