• When trying to update from version 2.2.22 to 2.2.23, it fails every time. Other plugins update just fine. The error is:

    Update Failed: Internal Server Error

    We tried to increase the memory limit, but it still failed. Any thoughts on what might cause this?

    Here are some of the errors in the logs. I replaced the actual site name with “sitename”

    [Sat Apr 07 13:58:25 2018] [warn] [client 71.244.230.47] mod_fcgid: stderr: #1 [internal function]: WP_Installer->plugin_upgrade_custom_errors(”), referer: https://www.sitename.net/wp-admin/plugins.php
    [Sat Apr 07 13:58:25 2018] [warn] [client 71.244.230.47] mod_fcgid: stderr: #2 /var/www/vhosts/sitename.net/httpdocs/wp-includes/class-wp-hook.php(286): call_user_func_array(Array, Array), referer: https://www.sitename.net/wp-admin/plugins.php
    [Sat Apr 07 13:58:25 2018] [warn] [client 71.244.230.47] mod_fcgid: stderr: #3 /var/www/vhosts/sitename.net/httpdocs/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(”, Array), referer: https://www.sitename.net/wp-admin/plugins.php
    [Sat Apr 07 13:58:25 2018] [warn] [client 71.244.230.47] mod_fcgid: stderr: #4 /var/www/vhosts/sitename.net/httpdocs/wp-includes/plugin.php(453): WP_Hook->do_action(Array), referer: https://www.sitename.net/wp-admin/plugins.php
    [Sat Apr 07 13:58:25 2018] [warn] [client 71.244.230.47] mod_fcgid: stderr: #5 /var/www/vhosts/sitename.net/httpdocs/wp-admin/admin-ajax.php(97): do_action(‘wp_ajax_update-…’), referer: https://www.sitename.net/wp-admin/plugins.php
    [Sat Apr 07 13:58:25 2018] [warn] [client 71.244.230.47] mod_fcgid: stderr: #6 {main}, referer: https://www.sitename.net/wp-admin/plugins.php
    [Sat Apr 07 13:58:25 2018] [warn] [client 71.244.230.47] mod_fcgid: stderr: thrown in /var/www/vhosts/sitename.net/httpdocs/wp-content/plugins/types/vendor/otgs/installer/includes/class-wp-installer.php on line 1387, referer: https://www.sitename.net/wp-admin/plugins.php

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Christian

    (@christianglingener)

    Sorry for the late response.

    You use our Installer (/wp-admin/plugin-install.php?tab=commercial) to update the plugin and not the plugins overview page (/wp-admin/plugins.php) right?

    If so can you please try to re-register and update again.

    I tried to update it from the overview page and the dashboard > updates area. Like all other plugins I update. Are you saying I need to update it manually?

    When I logged in today, I was greeted by an error message. I unfortunately did not copy the message, but did grab the code it said to add to my wp-config.php file:

    define(“OTGS_DISABLE_AUTO_UPDATES”, true);

    Plugin Author Christian

    (@christianglingener)

    The problem is that your server is not able to communicate with our server. That’s the reason for the error on update and also the reason for the admin notice you get.

    For sure the error on update shouldn’t be like that and I will communicate with the reasonable developers to improve the error handling.

    As I’m not your server administrator it’s hard to debug why your server does not allow/being able to communicate with ours. Manual update would just be a workaround.

    All the other plugins I update have no trouble communicating, so I think it is less a problem with the server and more a problem with the update. I will manually update it.

    Plugin Support Beda

    (@bedas)

    Manually updating will solve this problem, correct.

    Our Developers are improving the code, as Christian outlined above.

    Please let me know if you need any other help installing the Types Plugin.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Update to version 2.2.23 Fails’ is closed to new replies.