Support » Plugin: Query Wrangler » update to php 7

  • Resolved kwelch28

    (@kwelch28)


    We are trying to update our server to PHP7 and after running a compatibility check we found the following.

    FILE: /nas/content/live/rcrwireless1/wp-content/plugins/query-wrangler/includes/query.php
    ————————————————————————————————–
    FOUND 1 ERROR AFFECTING 1 LINE
    ————————————————————————————————–
    380 | ERROR | preg_replace() – /e modifier is deprecated since PHP 5.5 and removed since PHP 7.0
    ————————————————————————————————–

    Is there any plans to fix this?

    Thank you,

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Jonathan Daggerhart

    (@daggerhart)

    Hi kwelch28,

    Happy to take a look at this. I’ve submitted an issue over at the github repo. If you have any additional thoughts or insight around resolving it, please let me know.
    https://github.com/daggerhart/query-wrangler/issues/14

    Thanks for the report!

    Hi Jonathan,

    I wanted to follow up with you to se if there was any update on the request for PHP 7 compatibility with query wrangler?

    Thanks!

    Plugin Author Jonathan Daggerhart

    (@daggerhart)

    Hi Kwelch28,

    Thanks for pinging me on this again. I made the change and pushed a new version (1.5.43) that uses preg_replace_callback instead of preg_replace with the ‘e’ flag.

    Please let me know if you run into any more issues with PHP 7 (or anything else).

    Jonathan

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘update to php 7’ is closed to new replies.