WordPress.org

Support

Support » Plugins and Hacks » Akismet » Update to Akismet 2.5.6 fails with WP 3.1.4

Update to Akismet 2.5.6 fails with WP 3.1.4

  • The following error message comes up only when Akismet 2.5.6 is activated:
    Warning: Missing argument 2 for wp_widget() in /usr/local/pem/vhosts/267049/webspace/siteapps/143501/htdocs/wp-includes/widgets.php on line 76

    Version 2.5.3 had been working without problems. I’d like to go back to it.

    http://wordpress.org/extend/plugins/akismet/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Joseph Scott

    @josephscott

    The proper fix is to upgrade from PHP 4 to PHP 5.2 or higher. WordPress no longer supports PHP 4.

    That’s nice when you control the server but most of us are tenants on a bigger system and the php version is what it is. I’d be happy to go back to akismet 2.5.3. Using older versions isn’t mentioned on the Akismet site so I shall just have to not use it at all.
    roy547

    Plugin Contributor Joseph Scott

    @josephscott

    Version 2.5.3 of the plugin is available at http://downloads.wordpress.org/plugin/akismet.2.5.3.zip

    If your host isn’t willing to update versions of PHP that have officially been deprecated years ago then it is time to start looking for a better host.

    Moderator Sergey Biryukov

    @sergeybiryukov

    WordPress Dev

    The proper fix is to upgrade from PHP 4 to PHP 5.2 or higher.

    Agreed. However, Akismet 2.5.6 still lists WordPress 3.0 as the minimum required version.

    It guess either the required version should be bumped to 3.2, or a PHP 4 constructor should be added to akismet/widget.php.

    esmi

    @esmi

    Forum Moderator

    Akismet 2.5.6 still lists WordPress 3.0 as the minimum required version.

    We’ve asked the Akismet people to look into this.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Update to Akismet 2.5.6 fails with WP 3.1.4’ is closed to new replies.
Skip to toolbar