Support » Plugin: Smart Variations Images for WooCommerce » Update to 5.0 (from 4.0.59)

  • Resolved altercat

    (@altercat)


    Hello,

    I’m using the free version, what’s the right way to update to the latest version?

    I’m stuck at 4.0.59. When trying to update the usual way it asks me to purchase a license…
    Don’t want to lose any of the settings / configuration.

    Regards and thanks in advance

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author David Rosendo

    (@drosendo)

    Hello,

    Months ago I had a sticky post explaining the issue.

    https://wordpress.org/support/topic/cant-update-to-4-0-60/

    Delete plugin and install new one.

    Cheers,
    David

    Thread Starter altercat

    (@altercat)

    Thanks for the prompt reply David

    I did see that post. However I tried on my staging site and after deleting 4.0.59 and installing 5.0 all my product variations lost their pictures. They were instead all set in the product’s main gallery.

    Regards

    Plugin Author David Rosendo

    (@drosendo)

    Hello,

    I don’t delete SVI galleries. 4.0.59 had a bug and should have been updated at the time so that information is stored properly.
    You can download the 4.0.60 from here https://pt.wordpress.org/plugins/smart-variations-images/advanced/

    But I think you will experience similar issue. Where you using galleries with more than 1 attribute?

    Cheers,
    David

    Thread Starter altercat

    (@altercat)

    I downloaded 4.0.60 and will try updating to this first.

    Not sure I understand what you mean with “galleries with more than 1 attribute”. I had one gallery for every product variation (three variations per product), each variation had one attribute only.

    Plugin Author David Rosendo

    (@drosendo)

    Hello,

    But did the SVI galleries get altered when you updated to 5?
    Its normal to have all the images in the product gallery since SVI is kind of the product gallery organizer. SVI gallery is like of a extensions of the product gallery but you can see tem organized.

    Cheers,
    David

    Thread Starter altercat

    (@altercat)

    Hi again

    after manual update to 4.0.60 everything functions as expected. If I then update to 5.0, the images from the gallery are not displayed. Strange, cause in the “SVI Variations Gallery” in the Product Data both the galleries and their images are OK, but they are then not displayed. More interestingly, the first of the galleries (and its images) in one product is displayed, but further galleries are not.

    Thanks

    Plugin Author David Rosendo

    (@drosendo)

    Hello,

    I cant fully understand what is happening. Maybe you can contact me via http://www.smart-variations.com and provide some access to me so that I can check it out?

    I will be out for a few hours but I will look at it asap.

    Cheers,
    David

    Thread Starter altercat

    (@altercat)

    Ok will do, thanks a lot David. Will get in touch and give you access to the site before the upgrade — then you can play around and see what breaks when updating.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.