WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Update to 4.3 will no longer let me save the settings

[Resolved] Update to 4.3 will no longer let me save the settings

Viewing 8 replies - 1 through 8 (of 8 total)
  • I just removed the plugin and reinstalled and I still cannot make any changes to the settings… the save button just does not seem to work.

    Plugin Author John Havlik

    @mtekk

    What changes to the settings are you trying to make? By chance are you trying to change any of the breadcrumb templates (and use a tag other than a, span, or img)?

    Same issue here cannot save any settings.

    For example, I am trying to change Page Template on the Post Types Tab from:

    <a title="Go to %title%." href="%link%">%htitle%</a>

    to :

    <li><a title="Go to %title%." href="%link%">%htitle%</a></li>
    as I want to use list items, but it won’t save.

    Plugin Author John Havlik

    @mtekk

    Dave,

    You should be using bcn_display_list() if you want the breadcrumbs wrapped with <li> tags. See http://wordpress.org/support/topic/custom-mark-up-not-being-saved?replies=4

    Ahh OK. It wasn’t obvious that I should do that at all. Also, the latest update broke breadcrumbs layout without any warning that I needed the new function.

    (suppose I should have read the docco)

    Plugin Author John Havlik

    @mtekk

    The bcn_display_list() function has been around for years now (since 3.2.0, which was released almost 4 years ago), and has been the only officially supported way of wrapping the breadcrumbs with <li> tags. Honestly, I never thought so many people would do things the ‘hard’ way and manually add the <li> wrapping tags to each breadcrumb template. In the end, I need to beef up the documentation to make this more obvious.

    Haha, you’re right. My fault as I should have read the documentation. I’m ashamed as I am a developer and should have known better 🙂

    Always expect users to do the unexpected!

    Thanks.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Update to 4.3 will no longer let me save the settings’ is closed to new replies.