Support » Fixing WordPress » Update to 3.8.1 could not establish a secure connection to WordPress.org

  • Resolved MarkRH

    (@markrh)


    When trying to use the internal Update button, the browser just spins it’s wheels. When looking at the PHP error log, I have this:

    [24-Jan-2014 06:25:15 UTC] PHP Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /(path)/wp-admin/includes/update.php on line 117

    I installed the Background Updater Tester plug-in just to see what it had to say and it shows the following:

    PASS: Your WordPress install can communicate with WordPress.org securely.
    PASS: No version control systems were detected.
    PASS: Your installation of WordPress doesn’t require FTP credentials to perform updates.
    WARNING: Couldn#8217;t retrieve a list of the checksums for WordPress 3.8. This could mean that connections are failing to WordPress.org.

    I know I can do a manual upgrade but this is a pain. It used to work fine (I did perform a manual upgrade to version 3.8 due to the same issues.)

    Anyway, what should be my next troubleshooting or investigatory steps be?

    Thanks,
    Mark H.

Viewing 13 replies - 1 through 13 (of 13 total)
  • I have the same problem 🙂

    I have the same problem, alongwith a non-working ftp over ssl (which was working perfectly on 3.8), the ftp log says the login was successful, so I am at a “duh !!!!” :-D, so I am curious to know, if 3.8.1 is really that serious an update, is it ok to roll back at stay with 3.8 ???

    Well, since I figured the amount time it would take to troubleshoot this I could have updated my blog manually 20 times or something, I updated it manually. I created a zip file that contained only the modified files.

    Such a shame.. this automatic update stuff was supposed to make it easier. The opposite has occurred for me. I now have to go back to doing updates manually.

    For now I have disabled Automatic Updates in my wp-config.php file since it’s never worked anyway. My guess is whatever connection/communication method the automatic updates uses, the Update button also uses which causes it to fail as well.

    The error message contains too little information. Is my server rejecting WordPress.org and its certificate or is WordPress.org rejecting my server’s certificate and, if so, why?

    According to that Tester plug-in, it’s able to make a secure connection but, apparently, not able to do anything over it?

    Anyway, is there some way to revert back to what the Update button used to do as far as how it communicates with WordPress.org or perhaps some way to not verify certificates(at least as a test)?

    Ehh.. I guess it’s kinda moot now since I’ve upgraded it and can’t do any testing. Perhaps I’ll make a new 3.8 test blog at my webhost so I can do testing with that. That might be the best approach so I don’t hose my actual blog. I do have a local test blog on my PC but automatic updates worked fine with it. I have since disabled automatic updates on it as well.. that way I can backup files without them being over-written without my knowledge.

    I am not marking this as resolved because the actual problem still remains. Be real easy if I knew what to actually fix LOL.

    Ok, I’ve created a new test blog that’s on 3.8. Not sure if related but in the Admin dashboard I am getting this in the WordPress news section (happens in production blog as well):

    RSS Error: WP HTTP Error: Operation timed out after 10000 milliseconds with 159140 out of 232141 bytes received

    Perhaps the two are related.

    Updating gives the same symptoms:

    [25-Jan-2014 00:30:38 UTC] PHP Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /(testpath)/wp-admin/includes/update.php on line 117

    I think my issue is resolved. The NIC on the server was changed as a result of file transfers being too slow when FTPing stuff to it. It was like 110Kbps. After they changed some settings and is now getting 0.5Mbps or so, my test blog must have auto-updated itself to 3.8.1.

    My main blog also now does not get the RSS time out error. I am going to revert my test blog back to 3.8 and try again using the Update button. Apparently I had not disabled auto updates correctly in wp-config.php.

    Yep. That fixed it. Was able to update to 3.8.1 without any issues after the NIC settings were changed on the server. Here’s what they did:

    Thank you for your patience. At this time our System Administrators have increased the port speed to 1000Mb/s:

    =======================
    Speed: 1000Mb/s
    Duplex: Full
    Port: Twisted Pair
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: g
    Wake-on: g
    Current message level: 0x000000ff (255)
    Link detected: yes
    =======================

    This should help with transfer times on the server. If you have any questions or concerns, please let us know.

    So I guess my problem was that it was just taking too long for the transfer to occur between the server and wordpress.org and it just timed out. Marking this as resolved. Everyone else in this thread might want to create their own topic for support.

    If you happen to be on a host with no secure connection for the admin,
    just add those SSL constants in your config:

    define(‘FORCE_SSL_LOGIN’, false);
    define(‘FORCE_SSL_ADMIN’, false);
    define(‘FORCE_SSL’, false);

    That’ll takes care of the warnings. For those who may have this problem.

    Err no never-mind, ignore the above!

    So finally what is the solution?

    huemanfoo

    (@huemanfoo)

    I’ve been getting this warning on almost EVERY update/installation!
    This morning I tried something – I added the following line in the end of my config.php file:
    define(‘WP_HTTP_BLOCK_EXTERNAL’, false);
    AND IT WORKS!!! No more errors/warnings – all just runs smoothly!
    Just wanted to share this – not sure if it’s really a fix…

    umarizal

    (@umarizal)

    For me, the hint friend huemanfoo did not work …

    I had encountered the same problem and was able to fix it.

    The problem is regarding the secured connection from your server to wordpress.org.

    This connection uses port 443. You can ask your system administrator to allow this connection.

    Port 443 outgoing should be allowed.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Update to 3.8.1 could not establish a secure connection to WordPress.org’ is closed to new replies.