Support » Plugin: WP eCommerce » Update to 3.8 version

  • ewas


    I did Update of the plugin (by clicking Update in Installed plugins in my WordPress).

    I then got a red box at the top saying:

    Your WP e-Commerce data needs to be updated. You’ve upgraded from a previous version of the WP e-Commerce plugin, and your store needs updating.
    You should update your database for your store to continue working.

    I have 36 products currently. Had to refresh page several times to get most of my products updated and display them on the website (as they disappeared on update).
    Normally on a refresh I got a few more products updated so the number (example below) was rising eg. displayed 6/36 then 8/36 and so on.

    The problem is it’s got stuck on the last product – it says now:

    Update WP e-Commerce

    Updating Categories…

    Updating Variations…

    Updating Products …

    Estimated time left:Under a minute

    I already refreshed page several times and still getting stuck on the same number – 35.

    Not sure what I can do with it?
    When I go to Products page I still have a red message saying I need to update the plugin and the database to continue working.

    So I don’t know if I can just ignore it and edit my categories/ products or the plugin has not been updated correctly and I may brake it if I ignore the message and don’t finish it?

    (I already tried and can edit product info. Also on Installed plugins page it looks like the plugin is fine and doesn’t shout for the upgrade anymore.)


Viewing 3 replies - 1 through 3 (of 3 total)
  • ewas


    My products are messed up so their pages just display all products in the shop the way the main shop page does…

    If I add a new category or product their link just go to Page Not Found…

    So there is something wrong with the database
    And I don’t even have an option to delete the plugin… and start from scratch. Big bugger

    Anyone can help please?

    PS. The error message I get on the final refresh is:

    <div class="eta">Estimated time left:Under a minute</div>
    <b>Fatal error</b>
    : Maximum execution time of 30 seconds exceeded in
    on line
    Plugin Author Mihai Joldis


    You will have to increase max_execution_time = 360
    You can do that in a php.ini file or talk to your hosting provider and show them that error message.
    It is a hosting related issue.



    My hosting provider will not raise the max_exceution_time

    I managed to delete the plugin, reinstalled it and it works fine now.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Update to 3.8 version’ is closed to new replies.