Support » Installing WordPress » Update to 3.5 is showing "Fatal error: Cannot redeclare get_current_blog_id()"

  • Resolved Jason

    (@andbamnan)


    Hi,

    I’ve recently updated to WordPress 3.5, upon refreshing I am now being shown the message Fatal error: Cannot redeclare get_current_blog_id() (previously declared in /websites/123reg/LinuxPackage21/js/lu/ca/jslucas.com/public_html/wp-includes/load.php:676) in /websites/123reg/LinuxPackage21/js/lu/ca/jslucas.com/public_html/wp-includes/general-template.php on line 504

    Is there a solution to this issue without completely losing the theme? I’ve worked hard on the theme and would really not like to have to ditch it.

    Thank you,
    Jason

Viewing 2 replies - 1 through 2 (of 2 total)
  • esmi

    (@esmi)

    Forum Moderator

    Try:
    – switching to the default theme by renaming your current theme’s folder inside wp-content/themes and adding “-old” to the end of the folder name using FTP or whatever file management application your host provides.

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    – running the upgrade manually via wp-admin/upgrade.php

    Thank you so much – I was panicking when 3 out of 4 options didn’t work, but re-uploading the fresh WordPress download did it.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Update to 3.5 is showing "Fatal error: Cannot redeclare get_current_blog_id()"’ is closed to new replies.