WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Update to 3.4.1. problems

[Resolved] Update to 3.4.1. problems

  • I’m using WordPress for http://www.weeklyfun.nl and I’m very pleased with it.

    Recently I was asked to update to 3.4.1 and so I did.

    The update went well, I guess, but I got to a white screen with wordpress logo and the message that I had to update my database to complete the update.

    Updating the database doesn’t work, I only get a white screen and a wordpress logo, nothing more.

    This ended in the result that I can’t access my wp-admin anymore.

    Offcourse I have searched similar topics on this issue and followed all steps that was suggested by the helpers.

    – download fresh version and upload everything except wp-content
    – the steps to offset the plugins
    – the steps to go back to a previous version of WordPress
    and more I have tried.

    All I get is the white screen to update the database, nothing more.

    Please, I need help with this problem!

Viewing 15 replies - 1 through 15 (of 18 total)
  • I had exactly the same issue. Took me 2 nights to figure out so thought I should share how I got around it. I also tried all of those steps you mentioned above as well as many other things and had no luck. Here’s what did work for me in the end:

    Put blog url into this site:
    http://ismyblogworking.com/

    That told me I was still on version 3.3.2 (not 3.4.1 as I know was uploaded). To me I guessed that the database must not have actually been updated.

    I re-uploaded via FTP version 3.3.2

    That let me access the admin panel finally.

    I then deactivated all plugins. Tried updating at that point to 3.4.1 again but it failed.

    Next I installed and ran the following database clean up plugin: TentBlogger Optimize WordPress Database Plugin

    After that had run I was able to update to 3.4.1, and reactivate all plugins without any problems.

    That’s what worked for me as with my host I have no access to the database (it’s a side blog off my main portfolio site). For people that do have cpanel access, you could try the following:

    Solution for WordPress WP-Options Issue – Database Upgrade Required

    For version 3.4.1, the database version (db_version in wp_options) changed to 21115.

    Good luck!

    Hey this is not a problem , this is just a step that you need to follow to update your database , your files has been updated successfully not the database , So when you hit this Url http://www.weeklyfun.nl/wp-admin/ you need to click “update WordPress database ” just do this and you will be able to see your dashboard , but for safe side take your database backup in your locale system.

    @jhaba That is how it “should” work. Unfortunately in this particular upgrade it would get stuck and not actually upgrade the database. All you would get is a blank screen and a continuous redirect to wp-admin/upgrade.php?_wp_http_referer=%2Fblog%2Fwp-admin%2F

    Has never been a problem for me upgrading the wordpress files or the database before, but after googling around seems like many have had this same problem with the continuous white screen loop.

    are you getting this screen after login

    @jhaba For me there was no login screen, just a blank page. I could get the login screen by going direct to the wp-login.php file, however after logging in it would just divert to a blank page at wp-admin/upgrade.php?_wp_http_referer=%2Fblog%2Fwp-admin%2F

    I have fixed my issue by using the steps outlined above so no need for me to reply any further. This topic should not be closed yet though as weeklyfun still needs to fix their site. My solution may or may not work for them, was just putting it out there in case it does.

    @damiancomans Thanks for your posts. I will give it a try.

    I have uploaded 3.3.2., but still keep getting the message “Database Update required”. I can not get into the admin anymore.
    I have cleared my browsercache, and still it didn´t work. I don´t understand it.

    Try deleting the browser history and cache (especially cookies) and give it a shot.

    John, I have tried that as well. Still no different result.
    It keeps getting the upgrade redirect to update database.

    Hi,

    Try to login still, and once you are redirected to the database page, try navigating to another URL, such as:

    http://www.yourwebsite.com/wp-admin/edit.php

    This should take you to the list of posts you have in the dashboard.

    John all admin urls are redirected to the upgrade page. So I cannot access any admin page.

    Still no solution…

    A scan of your site shows that it has NO CONTENT, or empty. That may be the reason all the methods fail. Please this report.

    Hi,
    using an sql client access your database and check the wp_options table and check the siteurl row, make sure it has the correct info, also you can check wp_posts and wp_postmeta to make sure your content is safe.
    There might be some server settings that won’t allow php to change your database, it might have only content read+write rights and it might have no right over the “alter” command in mysql so contacting the hosting company wouldn’t be a bad thing…
    Regards

    jnhghy:

    Where you say wp_… I use wf2012_…
    – siteurl row in wf2012_options is correct
    – al data is still in the dbase

    I have all the needable serverrights, it should work fine. With other sites the update went fine, except this one.

    First check your tables for errors you might have a broken mysql database if that’s not the thing …
    At that point what I would do if I were you would be to backup my database and site and reinstall the website without the database to see if you can make that work after that populate the database with the info you have now…

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Resolved] Update to 3.4.1. problems’ is closed to new replies.