WordPress.org

Support

Support » How-To and Troubleshooting » Update to 3.4 echos warnings on theme Editor page

Update to 3.4 echos warnings on theme Editor page

  • After updating to 3.4 10 minutes ago, I started checking out the new updates. Everything was good until I got to the Editor page in the Dashboard. The following warnings below were echoed.

    Is this happening to anyone else? Is there a fix?

    Warning: preg_grep() expects parameter 2 to be array, null given in /path/to/files/wp-content/themes/genesis/lib/admin/editor.php on line 39

    Warning: Illegal offset type in /path/to/files/wp-content/themes/genesis/lib/admin/editor.php on line 39

    Warning: Illegal offset type in /path/to/files/wp-content/themes/genesis/lib/admin/editor.php on line 40

    Warning: preg_grep() expects parameter 2 to be array, null given in /path/to/files/wp-content/themes/genesis/lib/admin/editor.php on line 40

    Warning: Illegal offset type in /path/to/files/wp-content/themes/genesis/lib/admin/editor.php on line 40

Viewing 4 replies - 1 through 4 (of 4 total)
  • @dante7921,

    Looking at the file paths you’ve pasted that is an issue with the theme. Luckily, they are warning so should not stop your site working but you need to check for a theme update.

    esmi

    @esmi

    Forum Moderator

    Are you running with WP DEBUG on?

    Warnings also show when debug is set to “false”
    This is a Genesis issue and Studiopress is aware of it and has anwered this:

    This will be addressed in an update, but you should be fine to keep running Genesis

    esmi

    @esmi

    Forum Moderator

    Thanks. Info filed for future use. 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Update to 3.4 echos warnings on theme Editor page’ is closed to new replies.
Skip to toolbar