Support » Installing WordPress » update to 3.0.5 hangs at unpacking

  • royatl

    (@royatl)


    attempting to upgrade an installation from 3.0.4 to .5 .

    Update page shows:
    ———————————
    Downloading update from http://wordpr…etc.
    Unpacking the update…
    ———————————

    And that’s it. Site is still accessible.
    In wp-content there is wordpress-3.tmp.
    In wp-content/upgrade there is wordpress-3.tmp folder.
    When I try to go into that folder, nothing happens.

    This is Godaddy.com, Windows 4GH. Self-installed. I’ve upgraded other installs before on it; for instance, 3.0.3 to .4 . And I just upgraded two others on the same setup with no problems.

Viewing 15 replies - 1 through 15 (of 38 total)
  • tommcgee

    (@tommcgee)

    This has happened to me twice in a row now, with two different sites. It’s hanging at “Installing the latest version…”

    The solution is, find the file at the root level of your blog called “.maintenance” (that’s dot-maintenance) and delete it. For some reason the auto-update isn’t.

    Reload the dashboard and you should see that you’ve got the latest version.

    royatl

    (@royatl)

    This happens to me *before* .maintenance is created. Otherwise I wouldn’t still be able to access the site without first deleting .maintenance. And I do make the whole file tree writable for updating.

    The wp-content/upgrade/wordpress-3.tmp/ folder contains a partial unpacking of the zip file’s contents, so it is hanging while unpacking that.

    Thanks anyway.

    royatl

    (@royatl)

    Ok, so this appears to be specific to this type of Godaddy account, which is their new grid-based account (I’ve only tried the Windows side, not the Linux side, so don’t know if this is specific to Windows).

    In other words, the update goes well on my Windows Shared account and Linux Shared account, but not on the new Windows 4GH (grid) account.

    So, I’ll take this up with GoDaddy.

    If anyone else wants to share their experience, be my guest. I’ve changed the topic to “not a support question” since, for now, it is probably not a wordpress issue.

    amanda.everse@gmail.com

    (@amandaeversegmailcom)

    Since my upgrade to 3.0.5 last night, my entire dashboard has disappeared and will no longer give me access the admin area. The site is live and functional, and I have access via FTP, but there must be some sort of conflict with a plugin. I also did a separate akismet upgrade yesterday… and this WP update appears to have something to do with akismet. I also made some updates to the wordpress post tabs plugin, installing a script I generated at http://jqueryui.com/. I can’t even get a login dialog box. I just get a blank screen — not even an error message. Page source is blank.

    I’m having my host (hawkhost) restore the backup from the previous day, but now I’m not sure how or IF to upgrade. This seems like an important security update, but it also sounds as if 3.1 is also about to be released. Should I wait? Should I try uninstalling all my plugins before upgrading?

    eleanorb

    (@eleanorb)

    My upgrade never got beyond the “downloading” message, and I’m on Netfirms.

    Question: In manual mode, do I replace the entire folder Akismet with the new one, or transfer files in that folder one by one?

    govpatel

    (@govpatel)

    Before you update try and deactivate all plugins and then update as most of time it is plugin that cause the problem and then once updated activate one plugin at time.

    markg_montreal

    (@markg_montreal)

    Hello — I’m on Netfirms as well and I am also stuck on “downloading,” even after deactivating the plugins…

    rustypritchard

    (@rustypritchard)

    royatl: will you post your findings from GoDaddy here? I’m a GoDaddy user and had exactly the same experience of hanging at the unpacking stage. Thanks

    markg_montreal

    (@markg_montreal)

    I opened a ticket with Netfirms regarding this issue (also, plugins get stuck at “downloading” as well). I will post an update when they get back to me.

    wh1blog

    (@wh1blog)

    I have NEVER had any luck getting the “Update Automatically” to work for our site. Ever!

    It always gets stuck at the “Unpacking the update…”

    Help! The manual installation is a major pain in the…

    markg_montreal

    (@markg_montreal)

    it really does work like a charm usually….
    you should speak to your host — they will know if there is a permissions issue or another reason why it won’t work for you. it’s worth taking a few minutes to get it resolved — makes your web life a lot easier 🙂

    markg_montreal

    (@markg_montreal)

    from Netfirms:

    ————————
    At this time, we recommend our customers to manually update their plugins and WordPress versions manually via FTP to ensure all files are downloaded fully.
    ————————

    that doesn’t exactly explain what happened.
    let’s hope things go back to normal next time around.

    wh1blog

    (@wh1blog)

    I have to manually change the permissions for the wp-content folder, and when I do, it at least gets as far as getting stuck on that page. Without the permission changes, it won’t even get that far. I can see files on the server, but, nothing more stating anything is getting done beyond that “stuck” message.

    I was on Live Chat with my hosting for almost an hour trying to figure this out. I’m SURE it would be MUCH easier with the “automatic download…” Hence, why I was turning to here to try and find a solution.

    Any help would be greatly appreciated!

    eleanorb

    (@eleanorb)

    I’m a netfirms user. Automatic update has worked for me before, but I had to do manual this time, which was a lot more trouble.
    In answer to my own question, I replaced the entire folder wp-content/plugins/Akismet with the new folder, and that seemed to work okay. (The instructions are unclear about whether to replace the folder at this level (subfolder to wp-content) or to copy individual files in the folder…)
    Eleanor

    royatl

    (@royatl)

    Brief update: Haven’t gotten with GoDaddy about this since I have other fish to fry at the moment. However, I updated the Akismet plugin with no problem. WordPress update still hangs during unpacking.

Viewing 15 replies - 1 through 15 (of 38 total)
  • The topic ‘update to 3.0.5 hangs at unpacking’ is closed to new replies.