WordPress.org

Support

Support » Installation » Update to 3.0.4 Failed – Could not create directory.: /public_html

Update to 3.0.4 Failed – Could not create directory.: /public_html

  • This is the message appeared when I try automatic update in my 3.0.3 version to the 3.0.4 version. I have tried downloading the file and uploaded it via FTP manually but still no result.

    Any suggestions or comments…. Help….

    Thank you so much in advance.

    I wish everyone Happy New Year!

    Cheers,
    Foo

    This is the message I get…
    ———————————————————————-
    WordPress 3.0.4 is available! Please update now.
    An automated WordPress update has failed to complete – please attempt the update again now.

    Downloading update from http://wordpress.org/wordpress-3.0.4.zip…

    Unpacking the update…

    Could not create directory.: /public_html

    Installation Failed
    ———————————————————————-
    I installed my WordPress 3.0.3 to my sub-domain through my Host Provider.

    This is the site I am trying to update…
    http://uk.mytrade-community.com/main

Viewing 15 replies - 1 through 15 (of 35 total)
  • i have the same problem.. and instaling plugins too:/ hope we have an asnwer soon.
    Happy new year btw!!

    Hi fracky,

    Hope we get some answer soon…. Happy New Year to you too…
    In the meantime, keep searching around the forum… Hope to find similar post with solution… I’m trying a fresh Manual Install via FTP into another sub-domain… Hope that will work… Will post the result…

    Cheers,
    Foo

    That error usually happens when you run out of memory. Try turning off all your plugins before upgrading.

    The problem is that it’s a combo of server settings AND your install, so it’s not easy to prevent or debug (can’t test EVERYTHING after all).

    Or just do a manual upgrade.

    Hello Folks,

    I to am having this problem. I have had my PHP memory limit increased to 64M and I de-activated all my plug-ins.

    Is this a know bug in WordPress?

    Hi Ipstenu,

    Where can I check my memory? Btw, it’s actually a newly installed WP… With no plugins at all… Hmmmmmmmmmmmmmmmmmm……

    Cheers,
    Foo

    Happy New Year

    For me I go to cPanel and look at the section “software services” and choose “php configuration”. Mine shows directive memory limit 64M.

    When trying to WordPress Autoupdate, make sure that you FIRST:

    0. Delete the Upgrade folder completely from your server
    1. Go into your Plugins page
    2. Click the checkbox above all of them to select ALL plugins
    3. From the pulldown, select DEACTIVATE, then OK it
    4. Try the update again – that usually takes care of the errors for me.
    5. Don’t forget to re-enable your plugins as in Steps 1-3

    Mine shows 512M…

    Hi jpneok,

    My WP has no plugins at all because I just installed it…

    Cheers,
    Foo

    esmi

    @esmi

    Forum Moderator

    The problem is almost certainly due to your server’s configuration.

    http://wordpress.org/support/topic/30-upgrade-bug-ftps

    Thanks esmi, I’m gonna try this right now…

    Cheers,
    Foo

    When trying to WordPress Autoupdate, make sure that you FIRST:

    0. Delete the Upgrade folder completely from your server
    1. Go into your Plugins page
    2. Click the checkbox above all of them to select ALL plugins
    3. From the pulldown, select DEACTIVATE, then OK it
    4. Try the update again – that usually takes care of the errors for me.
    5. Don’t forget to re-enable your plugins as in Steps 1-3

    Tried all this and the result was Could not copy file.: /wp-admin/css/theme-editor.dev.css Which has been documented many times in the forums by others.

    Re: the pureftp to proftp issue I have read of people who this has not helped and my service provider claims that proftp is “Not seen this one before! If it is a bug with pure-ftpd then I’m afraid there is no recourse for action; Proftpd is slower, uses more memory and generally has a worse security record so we won’t be switching to it.”

    So I am back to a wordpress bug.

    esmi

    @esmi

    Forum Moderator

    I’m personally convinced that this is a server owner/permissions problem. Do you have access to the server’s error logs?

    Hmmm…. I have a little problem deleting the upgrade directory… scratching my head in the new year! Way to go!

    Keep on deleting the upgrade directory but it’s still there…. Arghhhhhhhhhhhhhhhhhhhhhhh

Viewing 15 replies - 1 through 15 (of 35 total)
  • The topic ‘Update to 3.0.4 Failed – Could not create directory.: /public_html’ is closed to new replies.
Skip to toolbar