Support » Plugin: File Away » Update to 3.9.7.7 produces empty listing

  • Resolved stoneyb

    (@stoneyb)


    As with htmanning’s problem, I updated from 3.9.6.1 to 3.9.7.7 and my file listings disappeared.

    This was reported to me on my main site, so I looked at my localhost copy, and found that it worked, but File Away was out of date. Once I updated it, it stopped working.

    I have WordPress in a sub-dir to my domain dir, /home/username/domainname/wp. The files I want to display are in /home/username/domainname/files, though. Something changed without my realizing it, since I used to be able to point File Away directly at this directory, but now I can’t edit the name through /wp. I added a symlink in wp/files that pointed at ../files, but that didn’t help. Going by your question about “..” in the path, I changed the symlink target to an absolute path, but that didn’t help either. Replacing the symlink with a copy of the files directory worked, though!

    I also tried adding a “..” to the base dir in File Away, but that didn’t work either.

    Ultimately, I moved the files dir into my wp dir and made a symlink to it from the domain root. This isn’t a good solution, as I’m more likely to delete my files dir accidentally.

    Is there a problem with File Away parsing “..” or opening dirs via symlinks?

    My main site is on a linux host and my development copy is on Mac. My Site Address and WordPress address are the same, and end in /wp.

    Thanks for any help getting this back to normal.

Viewing 7 replies - 16 through 22 (of 22 total)
  • Yes! It works with an absolute symlink but not a relative one (../files).

    Thank you so much!

    Plugin Author thomstark

    (@thomstark)

    Excellent to hear. Glad we got this fixed for you.

    Plugin Author thomstark

    (@thomstark)

    FYI, this is the first time File Away has OFFICIALLY and explicitly supported symlinks, so good job; you’re a mover and a shaker.

    Plugin Author thomstark

    (@thomstark)

    Hey, I just committed 3.9.8 which makes allowing symlinks an option on File Away Settings. It will be disabled by default. Please update and enable the setting. Thanks

    This update worked just fine, although like the two prior ones I’ve updated to today, it produced an error message in the plugin’s box on the plugin page, that said: “Update Failed: Plugin update failed.”

    The plugin files all appear to be correct, though. I don’t know what caused this. A DB update problem?

    So far as I can tell, though, it works, and has the “allow symlinks” option now.

    Thanks again!

    Plugin Author thomstark

    (@thomstark)

    Thanks for reporting back. I am not getting the Update Failed error on any of my sites. Nor am I getting any errors in the error log when updating. There’s no db stuff in these updates, so that wouldn’t be it. Do you happen to have your error log enabled in your wp-config.php? It could be another plugin interfering somehow which is why I’m not seeing it. Next time you do update, if you feel like it, enable your error logging first to see if it gives us a specific clue. Thanks again

    Plugin Author thomstark

    (@thomstark)

    Hey, @stoneyb

    Sorry, I found a small bug in 3.9.8 on the symlink validation. The way I wrote it, it would have only validated one child-directory deep on a directory tree nav. E.g.,

    base = /path/to/wp/symlink where symlink = /path/to/files
    /path/to/files would validate
    /path/to/files/sub would validate
    but /path/to/files/sub/sub would not validate, or anything thereafter.

    This is fixed now, in 3.9.8.1. It will now validate infinite levels deep, as it should have to begin with.

    Now’s a golden opportunity to turn on your error log before you update, if you’re so inclined. See if we can catch this installation error of which you speak.

Viewing 7 replies - 16 through 22 (of 22 total)
  • You must be logged in to reply to this topic.