Support » Plugin: WooCommerce » Update to 3.3.5 breaks site

  • Resolved dfilchak

    (@dfilchak)


    Was foolish and did not try this update on staging server first as I was in a hurry (no excuse I know). Now the site is really baffed. I canot give you a stsus readout as the site will not do that now but here is the error:

    Fatal error: Uncaught Error: Call to undefined function wc_get_attribute_taxonomies() in /home/zukamusic/public_html/wp-content/plugins/real-category-library/inc/general/WooCommerce.class.php:21 Stack trace: #0 /home/zukamusic/public_html/wp-content/plugins/real-category-library/inc/general/WooCommerce.class.php(13): RCL_WooCommerce->applyHierarchicalAttributes() #1 /home/zukamusic/public_html/wp-includes/class-wp-hook.php(286): RCL_WooCommerce->init(”) #2 /home/zukamusic/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #3 /home/zukamusic/public_html/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #4 /home/zukamusic/public_html/wp-settings.php(450): do_action(‘init’) #5 /home/zukamusic/public_html/wp-config.php(94): require_once(‘/home/zukamusic…’) #6 /home/zukamusic/public_html/wp-load.php(37): require_once(‘/home/zukamusic…’) #7 /home/zukamusic/public_html/wp-blog-header.php(13): require_once(‘/home/zukamusic…’) #8 /home/zukamusic/public_html/index.php(17): require(‘/home in /home/zukamusic/public_html/wp-content/plugins/real-category-library/inc/general/WooCommerce.class.php on line 21

    I have downloaded another version (rather than use the dashboard) and ftp’d it to the server but it produces the same result.

    Any help is very much appreciated as the site is totally non-functional.

    Dave

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Well, it seems to have cleared up …..which worries me! I replaced the 3.3.5 version with the previous version from a backup, removed the real categories plugin and it worked again. I then, this time on the staging server, upgraded the plugins, as I did on the live server, installed the real categories plugin and it worked fine. So, I updated the woocommerce plugin to 3.3.5 on the live server and then re-installed the real categories plugin and all seems fine.

    It is worrisome when this stuff happens.

    Anyway, sorry for the noise.

    Dave

    I had to re-upload version 3.3.4 as well my site stopping handling came up with this error.

    This page isn’t working
    MySite is currently unable to handle this request.
    HTTP ERROR 500

    Reload

    I fixed it I disabled a plugin or two and manually uploaded the woocommerce new version. I also did a debug in the wp-config file to see what plugin was acting up. Once I got the woocemmerce uploaded and activated I turned the other 2 plugins back on and now its all good.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Update to 3.3.5 breaks site’ is closed to new replies.