Support » Plugin: WooCommerce » Update to 2.1, Fatal error, class not found

  • Receiving this error after upgrading. I’m able to upload the old widgets back into the /widgets/ folder and connect them up again to clear the error, but I’d like to know what I’m missing that would be causing the issue.

    Fatal error: Class 'CI_WC_Widget_Best_Sellers' not found in /home/.../public_html/wp-includes/widgets.php on line 324

    If I re-add each old widget one-by-one, the error pops up for the next old widget.

    Important notes:

    1. I do not have any WooCommerce widgets active in the theme
    2. The theme is WooTheme’s Intrigue theme.

    https://wordpress.org/plugins/woocommerce/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Roy Ho

    (@splashingpixelscom)

    WooCommerce doesn’t have a widget class by that name. Check if you have a 3rd party plugin that is causing that issue.

    Thanks Roy. Appears that the Intrigue theme has a few of its own that may be triggering the error.

    Hey Dan. I’m having same issue with Intrigue theme. How did you resolve this issue?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Update to 2.1, Fatal error, class not found’ is closed to new replies.