Support » Plugin: WooCommerce » update to 2.0.16 broke attributes

  • Resolved ultime

    (@ultime)


    Hi,

    as it happened to many people there i also had problems with attributes.

    I first lost attributes variation which showed as Pa_xxx; I solved it by going to each products backend page then Attributes>save attributes: all variations were back as before.

    However 3 or 4 attributes text disappeared from ALL products, there are still showing in backend but are not showing frontend.

    Any idea how to solve this?

    PS: I di the modification to the two files JS cookies AND added the code to the theme php files, it didn’t bring back any of the lost data frontend.

    Thanks

    http://wordpress.org/plugins/woocommerce/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Mike Jolley

    (@mikejolley)

    Could we get more info – i.e. names of missing attributes and terms, screenshots of your variations in the backend, link to the page on the frontend.

    Thanks

    thanks for your replys.

    link of a product:
    http://subliled.com/product/spot-de-plafond-cob-3w-amovible-aluminium-poli-copy/

    frontend printscreen
    http://asia-impex.com/help/backend.png
    backend printscreen
    http://asia-impex.com/help/frontend.png

    three attributes are missing in ALL articles attributes list.
    variations are ok now.

    missing attributes:
    Diamètre extérieur en cm. (text)
    Couleur de l’éclairage (select)
    Étanchéité (select)

    Plugin Author Mike Jolley

    (@mikejolley)

    I was worried it may be the special chars, but I’ve just added some random ones without issue: http://cl.ly/image/3R2J0y0n0u3V

    So, can you check if its caused by the theme, and if you are running it, WPML.

    thanks.

    I rolled back to Twenty Thirteen but nothing changed.

    I then have try other actions still on that theme:
    – unticked show those attributes, saved, ticked and saved again, no result.
    – deleted each values, saved, entered value again, saved, no result.
    – removed these attributes from the product, saved, added again, and now it’s worse only the first attribute appears but without value again and the two others attributes don’t show at all.

    http://subliled.com/product/spot-de-plafond-opaque-8w-rond-blanc-copy/#tab-additional_information

    Plugin Author Mike Jolley

    (@mikejolley)

    If you add a brand new similarly named attribute, does it display?

    If you export your content from tools > export I can import those products in and try it. I’m currently unable to reproduce this issue.

    Solved! well done Mike! I have checked the slugs before adding a new attribute and noted that these three slugs kept the special chars from the title, i have changed all these chars in slugs and attributes are now showing as before.

    It’s weird.

    I am sure 100% that I didn’t specify any slug and let WC create them.

    I just have try to create a new attribute with a special chars and the created slug was without the special chars. So I guess from time to time WC could create a slug with the original special chars.

    I remember now that there were one attribute I couldn’t load into a product, as it was not very important I gave it up… now that I have checked, this slug was also with a special character…

    But if I was able to add these 3 attributes into the product, does it mean that the update messed the slugs name?

    Hope I’m clear 🙂

    Thanks a lot for your help.

    solved btw.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘update to 2.0.16 broke attributes’ is closed to new replies.