Viewing 7 replies - 1 through 7 (of 7 total)
  • Our development team is aware about this bug already, but thanks for reporting anyway. We’ll be fixing this very soon.

    Hi Zactoff

    Thank you for this submission. Could you use this patch:

    Index: embedded/common/toolset-forms/bootstrap.php
    ===================================================================
    --- embedded/common/toolset-forms/bootstrap.php (revision 29615)
    +++ embedded/common/toolset-forms/bootstrap.php (working copy)
    @@ -256,8 +256,10 @@
                 $current_types = $query->get('post_type');
                 if(empty($current_types)) {
                     $cpt_to_add[] = 'post';
    +            } else if ( is_array($current_types) ) {
    +                $cpt_to_add = array_merge($current_types, $cpt_to_add);
                 } else {
    -                $cpt_to_add = array_merge($current_types, $cpt_to_add);
    +                $cpt_to_add[] = $current_types;
                 }
                 $query->set('post_type', $cpt_to_add);
             }

    Marcin

    Sure, where do I paste it? There are 165 lines in that file.

    Can you not just release an update to the plugin? I have a few other sites using it, some of which I don’t manage any more, it would be good to know my clients can safely update their plugins.

    Cheers,

    Worked it out, and while it has stopped the error message displaying, it’s also stopped any of my posts from listing.

    Hi Zactoff

    This is a patch file: http://en.wikipedia.org/wiki/Patch_%28Unix%29

    Delete line begins with “-” and add this begins with “+” or use patch program.

    Marcin

    Thanks Marcin, but as I said, your patch is causing more severe issues.

    For me Marcins fix worked fine.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Update to 1.6.4 causing error’ is closed to new replies.