Support » Plugin: Table Maker » Update to 1.9 Deletes all Content (kinda but not really fixed(

  • Some people suggest that deactivating/activating the plugin would bring their content back. This does not work for us, given the reasons I explain below:

    As part of the plugin update, the database-table storing the plugin content has changed.

    For us this update fails with dataloss: The new db table is never created, but the old is indeed deleted. The result is a complete loss of all data in this plugin.

    The solution is to:

    1. Have a backup you can restore to.
    2a. Update the plugin with an SQL Command that actually works.
    or
    2b. Manually transfer the data to the new table.

    in either case, the SQL used must be updated to escape the names of the columns rows and cols, such that:

    rows MEDIUMINT(9) NOT NULL,
    should become
    “rows” MEDIUMINT(9) NOT NULL,

    • This topic was modified 7 months, 4 weeks ago by  berndtl.
    • This topic was modified 7 months, 4 weeks ago by  berndtl.
    • This topic was modified 7 months, 4 weeks ago by  berndtl.
Viewing 8 replies - 1 through 8 (of 8 total)
  • I have the same problem. Had to revert back to 1.6 to fix.
    Any updates?

    Same here. Data in the database (table wpsm_tables) seems still to be here but are no longer displayed in admin panel and on website.

    Hope to get feedback from the developer soon.

    Okay – fast workaround which works for me:
    – copy table wpsm_tables to new table containing the DB prefix of your database (just use the same name as for all the other tables)

    If the data did not get lost during the update (was the case for me) all tables reappear in the admin panel and on the webpage.

    Help – have the same problem. SO frustrating!! The update wiped my data. No tables are showing up. I don’t have a good backup, so hoping that when I revert versions the data will still be there. It was a large table.

    How do I do that? I downloaded the older version, but when I tried to install, it said install failed. Do I need to uninstall the new version first? Will that delete any data that may still be there?

    Thanks.

    @hgassner how do I try that?

    UPDATE: I found another thread with this problem and they suggested deactivating the plug in and then reactivating. That worked for me. Thanks.

    I have deactivated the plugin, then I have activated it. It worked for me. The tables reappeared.

    Yep I lost all tables with 1.9.

    Activating and de-activating seemed to be the fix for me!

    Cheers folks.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Update to 1.9 Deletes all Content (kinda but not really fixed(’ is closed to new replies.