Support » Plugin: Constant Contact Forms » Update to 1.5.0 has created JavaScript errors on page editing

  • Resolved morgykat

    (@morgykat)


    This plugin on our website was updated to version 1.5.0 today.
    This has created cascading JavaScript errors in the WordPress backend when adding/editing a post/page.

    The problem was brought to us by our client who reported that the “Set Featured Image” link suddenly stopped working.
    We then observed JavaScript errors from load-scripts.php
    e.g.
    Uncaught TypeError: _.pluck is not a function
    Uncaught TypeError: Cannot read property ‘hasClass’ of undefined at HTMLDocument.
    etc
    etc

    Disabling the plugin and these errors go away.

    Can you please advise of a fix to this.

    many thanks

    Ian

Viewing 15 replies - 16 through 30 (of 43 total)
  • Same here! The editor did not work after updating from 1.4.5 to 1.5. You could not format text in the editor, nor use the Add Media. I reverted back to 1.4.5 and it works now.

    Plugin Author Constant Contact

    (@constantcontact)

    Good day everyone.

    First up, thank you for your patience with these issues. We hope we have found a breakthrough with the topic, and would appreciate some people testing out this version with some fixes/changes in place. We’re hoping this will solve the conflicts. If we get confirmations that users’ issues are resolved, we’ll release the changes to everyone.

    The plugin version number will still reflect “1.5.1” but it does have the hopeful fixing changes in place.
    https://www.dropbox.com/s/natpt2p4z7dspgg/constant-contact-forms-1.5.2-beta.zip?dl=0

    the beta update resolved the issues for me and I am now able to edit with wpbakery page builder.

    • This reply was modified 3 months, 1 week ago by  digitaliway.
    Plugin Author Constant Contact

    (@constantcontact)

    Good to hear @digitaliway. We’re waiting for more feedback from others with various plugin conflicts to confirm resolution as well before we look into rolling out to everyone.

    It works fine for me too, editor page and Add media work properly. Thank you!

    Plugin Author Constant Contact

    (@constantcontact)

    Thanks for helping confirm as well @lucianmih.

    We’re giving time for some more people to provide updated feedback as well, before we will release to everyone.

    @constantcontact Chiming in here, had the same javascript error/issue as OP. We tested the beta fix and we’re now able to use Visual Composer again to edit pages.

    Thanks!

    Just to confirm, beta version 1.5.2 fixed the problem for us too.
    Many thanks.

    Yes, beta version 1.5.2 fixed the visual builder problem.
    Thank you

    Plugin Author Constant Contact

    (@constantcontact)

    Thank you everyone.

    Plugin Author Constant Contact

    (@constantcontact)

    Please upgrade to version 1.5.2 that was just pushed out. Thanks.

    This plugin ver 1.5.2 still breaks my ability to use the page text editor.

    Plugin Author Constant Contact

    (@constantcontact)

    hey @tcolling can you provide more details about what errors you’re able to see? If you need help, we can provide some more steps to take to get to more information that can be provided to us.

    Also, just in case it’s playing a part, please clear your caches, even for the WP admin, in case you’re still loading 1.5.1 or earlier copies of javascript.

    Cache clearing, trying different browsers, etc already done. No help.

    It’s simple – we only have one client who uses this plugin. On their site, running WordPress 5.1.1, if your plugin is enabled, they cannot edit in “text” mode in the classic text editor – they just get a blank area with no toolbar unless they click back to the “Visual” tab in the classic editor.

    I just installed 1.5.2 and it removed my ability to edit posts and pages via WPBakery Visual Composer Editor.

    The options to edit the content using the visual composer editor are gone – no longer visible on the screen. The buttons reappear when I disable the Constant Contact plugin.

    I’ve cleared the page cache across the site. I’ve logged out and back in. I haven’t tried to uninstall and reinstall for fear of losing the forms that I have set up.

    Please advise.

    • This reply was modified 3 months, 1 week ago by  avazquez26.
Viewing 15 replies - 16 through 30 (of 43 total)
  • You must be logged in to reply to this topic.