Support » Plugin: PublishPress: Editorial Calendar, Workflow, Comments, Notifications and Statuses » Update to 1.21.1 results is error string(2) “no” for admin panel

  • Resolved tpnotes

    (@tpnotes)


    Hello,

    after updating the plugin to the version 1.21.0 I can no longer access the admin panel of WordPress. Error: string(2) “no”

    It is definitely PublishPress and I can reproduce it with two different installations. My WordPress is up to date 5.2.4

    Any ideas?

    Thanks in advance,
    tpnotes

Viewing 9 replies - 1 through 9 (of 9 total)
  • I am having the same problem with version 1.21.0.
    I used wp-cli to solve it for now:

    $ wp plugin list
    +---------------------------------------+----------+-----------+------------+
    | name                                  | status   | update    | version    |
    +---------------------------------------+----------+-----------+------------+
    [...]
    | publishpress                          | active   | none      | 1.21.0     |
    [...]
    +---------------------------------------+----------+-----------+------------+
    $

    Switch off:

    $ wp plugin deactivate publishpress
    Success: Plugin 'publishpress' deactivated.

    Admin menu is once again available…

    I confirm the error! I had to disable the plugin. Does the developer not test?!!!

    Plugin Author publishpress

    (@publishpress)

    Hi @antomal @evelien @tpnotes

    Our apologies for this. The PublishPress update is rolling out successfully to almost all sites, but there must be something about your setups that we missed in testing.

    It could be a particular hosting company, PHP version, or plugin conflict that we didn’t test for.

    Please email help@publishpress.com with some details of your setup and we’ll get this resolved.

    Plugin Author Kevin Behrens

    (@kevinb)

    Our whole team is working to correct this error as quickly as possible. We have identified the cause of the error and will release an update very soon.

    Plugin Author Kevin Behrens

    (@kevinb)

    @tpnotes @evelien @antomal PublishPress 1.21.1 is released to correct this error.

    That was really fast – thanks a lot!

    It works! Thanks guys!

    I have re-enabled the plugin in my site.

    Now the only confusing thing left in this discussion is that the fix is in the version that was named as the culprit in the title of this thread…

    It was my mistake, when starting that thread. Unfortunately, I can not change the title.

    This bug was in v1.21.0 and is fixed with v1.21.1

    Plugin Author publishpress

    (@publishpress)

    No problem @tpnotes – thanks for posting the clarification.

    Sorry about the original bug, everyone. Here’s a quick explanation of why our testing didn’t catch it … it only showed if you’d been using PublishPress for some time and had performed a particular action.

    After a month, a message pops up asking for a review of PublishPress here on WordPress.org. That message has 3 choices: “Yes”, “No”, or “Remind Me Later”.

    If you had clicked one particular choice, you saw this bug. For everyone else, version 1.20.0 worked OK.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Update to 1.21.1 results is error string(2) “no” for admin panel’ is closed to new replies.