Support » Plugin: W3 Total Cache » Update to 0.9.7.2 breaks forms

  • Resolved Plan9

    (@plan9)


    Updating to 0.9.7.2 breaks my themes inline forms functionality. Disabling HTML Minify fixes it.

    Original HTML:

    <input class="menu-search-field" type="text" onblur="if(this.value=='')this.value='To search, type and hit enter';" onfocus="if(this.value=='To search, type and hit enter')this.value='';" value="To search, type and hit enter" name="s" />
    </form>

    W3 Total Cache Minified HTML:
    <input class=menu-search-field type=text onblur="if(this.value=='')this.value='To search, type and hit enter';" onfocus="if(this.value=='To search, type and hit enter')this.value;" value="To search, type and hit enter" name=s></form>

    Seems to be stripping out CSS class quotation marks. For now I’m using another plugin called ‘Minify HTML’ which causes no problems.

    • This topic was modified 8 months, 3 weeks ago by Plan9.
Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,
    Yes, that’s true, it is stripping out CSS class quotation marks but that doesn’t break the HTML.
    We are will include the option to enable/disable the attribute quotes removal feature in future releases.
    Thank you for bringing this to our attention.

    Hi Marko

    Well it is definitely breaking the form (actually a search box in the theme header). The previous version of W3 Total Cache minified HTML without breaking anything. I think it’s better for me to downgrade to the previous version.

    BTW – I would not say that this is resolved. Will you be making changes to HTML minify in future releases? It’s disappointing that this is broken – especially as I bought the premium licence.

    • This reply was modified 8 months, 3 weeks ago by Plan9.
    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,
    As said previously we will include the option to enable/disable the attribute quotes removal feature in future releases.
    It is not broken, as this is normal behavior. please check this article https://mathiasbynens.be/notes/unquoted-attribute-values
    I’ll post a workaround fix for you until the update is released.

    A workaround fix would be very appreciated!

    Thank you

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello
    Can you please share your PHP and WP version?
    Also when you enable HTML Minify what other settings do you have enabled under HML&XML sub-box?

    Hi

    PHP= 7.2.15
    WP= 5.1

    In HTML minify plugin settings I have only the following set to ‘yes’:

    Minify inline JavaScript
    Remove HTML, JavaScript and CSS comments

    I tested ‘Remove XHTML closing tags from HTML5 void elements’ option, it seemed OK but I left it disabled.

    Thanks

    Hi Marko

    Do you need any more information?

    Thanks

    Hi Marko

    How do I access the workaround fix? Do I need to re-install 0.9.7.2 ?

    Thanks

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @plan9,

    Might be related to CSS/JavaScript searching for the element by attribute value. Not sure if quoted/unquoted attributes matters in that case, We think not, but we are testing it to be sure.
    Once again check this article for guidance https://mathiasbynens.be/notes/unquoted-attribute-values
    This is coming from guy that works in google, chrome engine project.

    I’ll post a workaround fix for you until the update is released.

    Where I can access the workaround fix you said you would post?

    Thanks

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Update to 0.9.7.2 breaks forms’ is closed to new replies.